2 Replies Latest reply on Jul 29, 2013 12:09 PM by Paul M.

    Am Unable To Execute the runInstaller Script To Install Oracle Grid Infrastructure


      Greetings To All!

      I have been spending the better part of this weekend trying (without any real progress) to install the Oracle Grid Infrastructure on my home PC as a precursor to later installing Oracle 11g Enterprise Database...

      The problem I am having is that I cannot seem to get the runInstaller command to execute. I am trying to run this (the runInstaller command) from DVD installation media installed in the DVD drive. The drive is mounted and I am able to successfully access the files in the mount point; but for whatever reason, the runInstaller command will not execute.

      Please note that I am logged in as user oracle (as required). I even tried to change the permissions on the runInstaller file so that I could execute the command and the OS would not even allow me to change permissions on the file. I am sure the solution is something probably very simple...but what? Any ideas? Please see down below the commands I ran and their results. Thanks! Rob

      oracle@new-host-3 grid]$ whoami
      [oracle@new-host-3 grid]$

      [oracle@new-host-3 grid]$ pwd
      /media/disk/grid                                                                                       #/media/disk/grid is the DVD drive mount point
      [oracle@new-host-3 grid]$

      [oracle@new-host-3 grid]$ ls -l
      total 26
      dr-x------. 9 oracle oinstall 620 Jul 20 21:02 doc
      dr-x------. 4 oracle oinstall 888 Jul 20 21:02 install
      dr-x------. 2 oracle oinstall 112 Jul 20 21:02 response
      dr-x------. 2 oracle oinstall 120 Jul 20 21:02 rpm
      -r--------. 1 oracle oinstall 3795 Jan 28 2009 runcluvfy.sh
      -r--------. 1 oracle oinstall 3227 Aug 15 2009 runInstaller                                #note that file permission is set to read only
      dr-x------. 2 oracle oinstall 112 Jul 20 21:02 sshsetup
      dr-x------. 14 oracle oinstall 2040 Jul 20 21:02 stage
      -r--------. 1 oracle oinstall 4228 Aug 17 2009 welcome.html
      [oracle@new-host-3 grid]$

      [oracle@new-host-3 grid]$ ./runInstaller
      bash: ./runInstaller: Permission denied
      [oracle@new-host-3 grid]$

      [oracle@new-host-3 grid]$ chmod 700 runInstaller
      chmod: changing permissions of `runInstaller': Read-only file system               #am unable to change permission on runinstaller to execute