6 Replies Latest reply: Aug 20, 2013 1:23 AM by Nitish.Nirala RSS

    rman parameter

    941949

      dear all,

                   i have mounted a 200gb external drive in linux rhel 6.7 .i want to take rman backup(11g db) and i have to store the backup to this mounted drive.my question is do i need to change the RMAN PARAMETER-CONFIGURE DEFAULT DEVICE TYPE TO DISK; your help appreciated thanks in advance.

        • 1. Re: rman parameter
          Asif Muhammad

          Hi,

           

          Not necessarily, if it is not a routine backup you are going to perform then you can simply do the following:

          Assuming external is mounted on /media/external:

           

          BACKUP

          AS BACKUPSET

          TAG 'FULL_DATABASE'

          FORMAT '/media/external/DBFILES_%F’;

          DATABASE

           

          In the above the FORMAT parameter defines the location.

           

          Hope this helps!

          Thanks &

          Best Regard,

          • 2. Re: rman parameter
            941949

            thank you for replying asif,but its a routine job for me to take rman backup on the mounted external drive.so please help what change i should make in the rman parameter :  DEFAULT DEVICE TYPE TO DISK;#

            • 3. Re: rman parameter
              Asif Muhammad

              Hi,

               

               

              Yes, you set to DISK

               

              You may have a consistent setting:

              Below command is set assuming your external is mounted on /media/external:

               

              CONFIGURE CHANNEL DEVICE TYPE DISK FORMAT '/media/external/DBFILES_%U';   

               

              Thanks &

              Best Regards,

              • 4. Re: rman parameter
                Hemant K Chitale

                Another option is to define the external disk mount point as your FRA -- db_recovery_file_dest   so that it becomes the default location for RMAN Backups without having to specify a FORMAT.

                 

                 

                Hemant K Chitale


                • 5. Re: rman parameter
                  941949

                  dear all,

                              why  i m getting this error when i try to configure this rman parameter,your help appreciated.

                  /u01 is the mount point.

                   

                  RMAN> configure default device type to disk format  '/u01/bkp_%s_%p';

                   

                   

                  RMAN-00571: ===========================================================

                  RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============

                  RMAN-00571: ===========================================================

                  RMAN-00558: error encountered while parsing input commands

                  RMAN-01005: syntax error: found "format": expecting one of: ";"

                  RMAN-01007: at  line 1 column 39 file: standard input

                   

                   

                  thanks and regards.

                  • 6. Re: rman parameter
                    Nitish.Nirala

                    Hi,

                    You can try below syntax:

                     

                    RMAN> configure default device type to disk;

                     

                    To specify location use channel configuration

                    RMAN> CONFIGURE CHANNEL DEVICE TYPE DISK FORMAT  '/u01/bkp_s%s_p%p';

                     

                    %s is backup set number

                    %p is backup piece number

                     

                     

                    to give more option for naming convention for backup piece you can use below format also

                    .......... format   '/u01/bkp_%d_%Y_%M_%D_%U' ;

                     

                    %d=DATABASE NAME

                    %Y=year (YYYY)

                    %M=Month (MM)

                    %D=Date ( DD)

                    %U=Unique Filenames

                     

                    Thanks and Regards

                    Nitish K nirala