This discussion is archived
0 Replies Latest reply: Aug 27, 2013 7:31 AM by smarty_card_pants RSS

64-bit Linux driver/associated SPE API for the Omnikey CardMan 3821 card reader

smarty_card_pants Newbie
Currently Being Moderated

I am in the process of converting from a 32 bit to a 64 bit Linux machine. In the past I was able to use the SPE API for 32 bit Linux along with the 32 bit Linux ifdokccid device driver. However, using the speapi_lnx-amd64-1.0.1 along with ifdokccid_lnx_x64-3.7.0 isn't working for me. For example, when I attempt to do an SCardCCIDVerifyPIN function call, I get back a 6B80 APDU response. I noticed that the ifdokccid for 64 bit Linux requires PCSC lite 1.5.5, but the SPE API requires PCSC lite 1.2.9-beta7, which I'm guessing is not compatible. I am wondering if anybody has any ideas about how I should proceed to get my OMNIKEY 3821 reader to work in a 64-bit Linux environment?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points