2 Replies Latest reply: Aug 28, 2013 6:54 AM by marcusafs RSS

    Logical diagram's relation lines invisible


      In my logical diagram and its subviews, a few of the lines (maybe 10%) representing relations aren't appearing between the entities.  The relations exist and appear to be defined just as the ones that do appear.  In "Show/Hide Relationships", they're flagged as selected, and I've tried clicking them off and on but it doesn't help.  In Preferences=>DataModeler=>Diagram=>Format, I've tried messing with the line widths to see if the change would affect the invisible lines, but no.  When engineered to a relational model, the corresponding foreign key's lines do appear.  If I create a subview from the entities that have relations between them, the lines don't appear on the subview either.  If I change the logical diagram's background color to red, the relations do appear in white (or maybe yellow), though in the narrowest width.  (That is, if I change the line width to fat and blank in Preferences, the 90% of the lines that usually appear are there in fat black, but the usually invisible ones are thin and white/yellow.)


      How can I get the missing lines to appear?  (SQLD

        • 1. Re: Logical diagram's relation lines invisible

          I guess all I needed to do was report it here in order to figure it out!


          How I fixed them:  Set diagram color to red so that they'd be visible.  Right-click the now-visible line to bring up a submenu.  Under Format, "Use default" was clicked off.  Click it on.


          How they managed to become un-default, I don't know, but they're better now.  I'll mark this answered but leave this here in case someone else stumbles into the same problem.

          • 2. Re: Logical diagram's relation lines invisible

            Go to your red background, select the yellow/white lines. right clidk, format, and check Use Default.  Make sure default is black.


            Marcus Bacon