11 Replies Latest reply on Sep 18, 2013 5:54 PM by AlexAnd

    Issue with special characters in XML reports

    N999

      Hi All,

       

       

       

      Issue 1) The problem is with special characters in xml publisher reports - like trademark symbol is converting into [XAE] value in xml file

      FYI,   -   XML File generated from Oracle Reports - Custom development.

      Example: My XML File has the following value in the tag

      "<PAY_TXT>PAY? Contact your bank or financial institution to make this payment from your cheque</PAY_TXT>"

       

       

       

      Issue 2) In RTF Layout Design, i have payment options like Telephone, Internet Web address, Post Bill Pay or by Cheque Options for the user to make the payment.

      Problem : XML tag values are not being displayed on  MS Word - Text Box (which consists of one above mentioned payment options Image).

       

       

      Can anyone suggest, how to resolve this issue ?

       

       

      Thanks,

        • 1. Re: Issue with special characters in XML reports
          AlexAnd

          with special characters

          try to escape xml value

          SQL> select utl_i18n.escape_reference('&') from dual

            2  /

           

          UTL_I18N.ESCAPE_REFERENCE('&')

          --------------------------------------------------------------------------------

          &amp;

           

          SQL>

           

          Example: My XML File has the following value in the tag

          "<PAY_TXT>PAY? Contact your bank or financial institution to make this payment from your cheque</PAY_TXT>"

          any problem with this?

           

          any samples of data will be useful

          • 2. Re: Issue with special characters in XML reports
            N999

            Hi,

             

            Thanks for your reply but i did not get anything from your replied message.  Please let me explain you my situation again.

             

            I am running Custom Concurrent Program which is of type Oracle Reports (Executable Method) and Output Format is " XML". So i expect Oracle Report to produce the output of XML File, when i run this Custom Concurrent Program from particular responsibility. Upto this everything is fine.

             

            But when i look into XML File => it generated XML Tags - this is fine ; but in one of the tag i need to have Super Script Value like " TM " (TradeMark).

            To my surprise it generated the following value in the XML Tag named "PAY_TXT".

            Example:

            Original (Coming - output):  "<PAY_TXT>PAYκ Contact your bank or financial institution to make this payment from your cheque, savings, debit or transaction account.</PAY_TXT>"

            Something like XAE or "K" after PAY Value in the xml tag and continued the text value.  (Tag value is not getting copied exactly here - i am sorry for that )

            Expected (output):  "Here it needs to produce the "PAY TM" (Here "TM" should be super scripted to "PAY" Value in tag).

             

            Thanks,

            • 3. Re: Issue with special characters in XML reports
              AlexAnd

              misunderstood =/

               

              Original (Coming - output):  "<PAY_TXT>PAYκ Contact your bank or financial institution to make this payment from your cheque, savings, debit or transaction account.</PAY_TXT>"

              it's in output but what is data in database ?

               

              sorry but without knowing about source data for forming the xml i haven't ideas about your problem

              in db it's "TM " or "™" or ... ?

               

              Original (Coming - output):  "<PAY_TXT>PAYκ Contact your bank or financial institution to make this payment from your cheque, savings, debit or transaction account.</PAY_TXT>"

              Something like XAE or "K" after PAY Value in the xml tag and continued the text value.  (Tag value is not getting copied exactly here - i am sorry for that )

              that's ok. i need to see the problem not the data as is

               

              Expected (output):  "Here it needs to produce the "PAY TM" (Here "TM" should be super scripted to "PAY" Value in tag).

              as super scripted in xml?

               

              as idea - you can have <PAY_TXT>PAY TM</PAY_TXT> and in publisher set TM as super

              Designing XSL Subtemplates - 11g Release 1 (11.1.1)

              1 person found this helpful
              • 4. Re: Issue with special characters in XML reports
                N999

                Hi AlexAnd,

                 

                yes you were right, in database column it was storing in that [XAE] format , so it is changed and got the correct xml tag value.
                But now the xml tags in text box are not getting printed ? What might be the reason for this  cause ?

                • 5. Re: Issue with special characters in XML reports
                  AlexAnd

                  so it is changed and got the correct xml tag value

                  correct xml tag value is ok

                   

                  plz post "correct xml tag value" sample

                   

                  But now the xml tags in text box are not getting printed ?

                  "printed" by printer or "printed" then you run bip to show output ?

                   

                  so post more detail about "printed" term

                  if you can then with example plz

                  • 6. Re: Issue with special characters in XML reports
                    N999

                    When i run the custom concurrent program from R12 - Receivables Manager Responsibility,

                    the RTF (output as PDF) is not printing the XML Tag Values within the Text Boxes used in the RTF Template.

                    Example:

                    As we cannot insert Text Fields in the Text Boxes, i used the following tag

                    <?TEL_NUM?> 

                    <?TEL_ADDRESS?>  etc in Text Boxes created through Microsoft Word Tool.
                    This is getting printed as it is instead of printing the XML Tag Value ( Example: 0428-5599-268  -  <?TEL_NUM?> ).

                    Can you suggest any solution and why this text box is behaving like this way ?

                    • 7. Re: Issue with special characters in XML reports
                      AlexAnd

                      As we cannot insert Text Fields in the Text Boxes, i used the following tag

                      why you need "Text Boxes" ?

                       

                      <?TEL_ADDRESS?>  etc in Text Boxes created through Microsoft Word Tool.

                      why not use a "Text Field" ?

                      Can you suggest any solution and why this text box is behaving like this way ?

                      use "Text Field"

                       

                      what are you trying to do using "Text Box" ?

                      • 8. Re: Issue with special characters in XML reports
                        N999

                        why you need "Text Boxes" ?

                        because i need to use this xml tag values on top of an client Specific image.


                        why not use a "Text Field" ?

                        Text Field is not allowed on Text Boxes and more over it can only be used in the tables and free text space of MS Word only.

                        • 9. Re: Issue with special characters in XML reports
                          AlexAnd

                          why you need "Text Boxes" ?

                          because i need to use this xml tag values on top of an client Specific image.

                          you can try to use <?TAG?> instead of Text Box or Text Field and set text on top of image (change image property)

                          i tried <?TAG?> and Text Filed and it work for pdf for "text on top of image (change image property)"

                           

                          why not use a "Text Field" ?

                          Text Field is not allowed on Text Boxes and more over it can only be used in the tables and free text space of MS Word only.

                          in header / footer you can use <?TAG?> instead of Text Filed

                           

                          so you can try a way with <?TAG?> instead of Text Box or you can post SR

                          not sure that Text Box will work correctly

                          • 10. Re: Issue with special characters in XML reports
                            N999

                            you can try to use <?TAG?> instead of Text Box or Text Field and set text on top of image (change image property)

                            i tried <?TAG?> and Text Filed and it work for pdf for "text on top of image (change image property)"

                            How to change the Image Property and what option to select ; when we right click on Image ?

                            Can you explain little bit clear. What is the option you have selected for editing the image and keeping <?TAG?> on top of the image.

                            • 11. Re: Issue with special characters in XML reports
                              AlexAnd

                              How to change the Image Property and what option to select ; when we right click on Image ?

                              Can you explain little bit clear. What is the option you have selected for editing the image and keeping <?TAG?> on top of the image.

                              Wrap Text Over The Image In Word 2010