5 Replies Latest reply: Sep 10, 2013 1:47 AM by JohnGoodwin RSS

    Issue with OHS (EPM) installation on Red Hat 6.4

    HyperionnEPM

      Hello Gurus,

       

      We are facing an issue with the installation of Oracle HTTP server which comes with EPM 11.1.2.2 using EPM Installer on Red Hat 6.4.

      When I select the OHS product it says, that the Oracle software is not certified on the current operating system, however it does not happen with any other product in the suite

      Is Red Hat 6.4 64 bit not a supported OS?

       

      I have installed all the required libraries mentioned here:  Oracle® Fusion Middleware System Requirements and Specifications

      Also my NPTL version is 2.12 which is higher than 2.3.4 as mentioned here: Oracle® Fusion Middleware System Requirements and Specifications

       

       

      Any help will be highly appreciated.

        • 1. Re: Issue with OHS (EPM) installation on Red Hat 6.4
          JohnGoodwin

          If it is in the support matrix then I think you should be able to ignore the warnings as the version of red hat was certified after that release of OHS

           

          Cheers

           

          John

          http://john-goodwin.blogspot.com/

          • 2. Re: Issue with OHS (EPM) installation on Red Hat 6.4
            HyperionnEPM

            Thanks a lot John.

             

            Seems like even though EPM Installer is giving a warning..It still installs OHS correctly.

             

            Would like to know your thoughts if it could cause issues in configuration activity?

            • 3. Re: Issue with OHS (EPM) installation on Red Hat 6.4
              JohnGoodwin

              If it is supported then it should be ok.

               

              Cheers

               

              John

              http://john-goodwin.blogspot.com/

              • 4. Re: Issue with OHS (EPM) installation on Red Hat 6.4
                HyperionnEPM

                John,

                 

                My installation went smooth, however when I start the configuration (Oracle Database) I am getting the following error while configuring the shared service registry:

                 

                Failed to navigate from RegistryWizardState: Error while initializing registry. See logs for more details.


                My DBA says that he has provided all the following privileges to the schemas.


                CREATE SESSION

                CREATE VIEW

                CREATE TYPE

                CREATE TABLE

                CREATE CLUSTER

                CREATE TRIGGER

                CREATE SEQUENCE

                CREATE INDEXTYPE

                CREATE PROCEDURE

                CREATE ANY SYNONYM

                DROP ANY SYNONYM

                UNLIMITED TABLESPACE


                configTool has the following exceptions:

                 

                [2013-09-10T10:44:53.748+05:30] [EPMCMN] [WARNING] [EPMCMN-01001] [oracle.EPMCMN] [tid: 10] [ecid: 0000K46JlSgAXNIMyqqYMG1IBegW000002,0] [SRC_CLASS: com.hyperion.cis.utils.oui.OUIUtilImpl] Failed to determine home via OUI: [[

                oracle.sysman.oii.oiii.OiiiInventoryDoesNotExistException: The inventory pointer location /etc/oraInst.loc is either not readable or does not exist

                    at oracle.sysman.oii.oiii.OiiiInstallAreaControl.initAreaControl(OiiiInstallAreaControl.java:1855)

                    at oracle.sysman.oii.oiic.OiicStandardInventorySession.initSession(OiicStandardInventorySession.java:292)

                    at oracle.sysman.oii.oiic.OiicStandardInventorySession.initSession(OiicStandardInventorySession.java:231)

                    at oracle.sysman.oii.oiic.OiicStandardInventorySession.initSession(OiicStandardInventorySession.java:180)

                    at com.hyperion.cis.utils.oui.OUIUtilImpl.inventoryTemplateMethod(OUIUtilImpl.java:289)

                    at com.hyperion.cis.utils.oui.OUIUtilImpl.findEpmOracleHomeFromInventory(OUIUtilImpl.java:67)

                    at com.hyperion.cis.utils.oui.OUIUtilLinkageErrorProtectionWrapper.findEpmOracleHomeFromInventory(OUIUtilLinkageErrorProtectionWrapper.java:18)

                    at com.oracle.preconfig.impl.InventoryPreConfigCheck.executeCheck(InventoryPreConfigCheck.java:23)

                    at com.oracle.preconfig.PreConfigCheckTemplate.execute(PreConfigCheckTemplate.java:9)

                    at Main.runPreconfigChecksAndExitIfFail(Main.java:142)

                    at Main.main(Main.java:90)


                 

                com.hyperion.hit.registry.exceptions.RegistryException: Unable to create registry.

                    at com.hyperion.hit.registry.RegistryConnection.createRegistry(RegistryConnection.java:354)

                    at com.hyperion.hit.registry.RegistryUtils.initUpgradeRegistry(RegistryUtils.java:272)

                    at com.hyperion.hit.registry.RegistryUtils.initRegistry(RegistryUtils.java:105)

                    at com.hyperion.hit.registry.Registry.createBasicComponents(Registry.java:2305)

                    at com.hyperion.config.document.Storage.initRegistry(Storage.java:245)

                    at com.hyperion.cis.config.ConfigRegistryUtils.initializeRegistry(ConfigRegistryUtils.java:384)

                    at com.hyperion.config.wizard.impl.RegistryWizardState$1$1.commit(RegistryWizardState.java:228)

                    at com.hyperion.hit.wizard.Wizard$NextClass.run(Wizard.java:544)

                    at java.lang.Thread.run(Thread.java:662)

                Caused by: java.sql.BatchUpdateException: error occurred during batching: ORA-01950: no privileges on tablespace 'HYPSS_DATA'

                 

                    at oracle.jdbc.driver.OracleStatement.executeBatch(OracleStatement.java:6390)

                    at oracle.jdbc.driver.OracleStatementWrapper.executeBatch(OracleStatementWrapper.java:248)

                    at com.hyperion.hit.registry.RegistryConnection.createRegistry(RegistryConnection.java:344)

                    ... 8 more

                 

                Any help will be highly appreciated.

                • 5. Re: Issue with OHS (EPM) installation on Red Hat 6.4
                  JohnGoodwin

                  The following is an Oracle database generared error:

                   

                  Caused by: java.sql.BatchUpdateException: error occurred during batching: ORA-01950: no privileges on tablespace 'HYPSS_DATA'


                  You need to check with the DBA as it does not look like the db account you are using has the correct privileges on the tablespace.


                  Cheers


                  John

                  http://john-goodwin.blogspot.com/