1 Reply Latest reply: Sep 9, 2013 12:25 AM by togotutor RSS

    SOA Server doesn't start

    cfd64e48-c763-4724-9aa9-2eb73ae04d3b

      Hello, I have just installed SOA server and when I try to run the SOA Server I get the following Error. I can access weblogic console and I dont see any SOA SERVER in the server section of the console.  I see 1 error

      The server name soa_server1 specified with -Dweblogic.Name does not exist. Could that be a reason? If yes please suggest me how to get over this problem.

       

      C:\Oracle\Middleware\wlserver_10.3\common\bin> startManagedWebLogic.cmd soa_serv

      er1 http://localhost:7001

       

       

      C:\Oracle\Middleware\wlserver_10.3\common\bin>echo off

       

       

      CLASSPATH=C:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\sys_manifest_classpa

      th\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_jdev1111\profiles\default\sys_man

      ifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\JDK160~1\lib\tools.jar;C:\

      Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;C:\Oracle\MIDDLE~1\WLSERV~

      1.3\server\lib\weblogic.jar;C:\Oracle\MIDDLE~1\modules\features\weblogic.server.

      modules_10.3.5.0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\webservices.jar;C:

      \Oracle\MIDDLE~1\modules\ORGAPA~1.1/lib/ant-all.jar;C:\Oracle\MIDDLE~1\modules\N

      ETSFA~1.0_1/lib/ant-contrib.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\common\derby\lib\d

      erbynet.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\common\derby\lib\derbyclient.jar;;C:\O

      racle\MIDDLE~1\JDK160~1\jre\lib\rt.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\

      webservices.jar;

       

       

      PATH=C:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\native;C:\Oracle\MIDDLE~1

      \patch_jdev1111\profiles\default\native;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\nat

      ive\win\32;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\bin;C:\Oracle\MIDDLE~1\modules\O

      RGAPA~1.1\bin;C:\Oracle\MIDDLE~1\JDK160~1\jre\bin;C:\Oracle\MIDDLE~1\JDK160~1\bi

      n;C:\product\11.2.0\dbhome_2\bin;C:\product\11.2.0\dbhome_1\bin;D:\app\Santosh\p

      roduct\11.2.0\dbhome_2\bin;C:\Program Files\Common Files\Microsoft Shared\Window

      s Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;D:\app\

      Santosh\product\11.2.0\dbhome_1\bin;C:\Windows\system32;C:\Windows;C:\Windows\Sy

      stem32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\W

      iFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files (x

      86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin

      \x64;C:\Program Files (x86)\Windows Live\Shared;D:\jdk\bin;C:\Program Files\Inte

      l\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Oracle\MIDDLE

      ~1\WLSERV~1.3\server\native\win\32\oci920_8

       

       

      ***************************************************

      *  To start WebLogic Server, use a username and   *

      *  password assigned to an admin-level user.  For *

      *  server administration, use the WebLogic Server *

      *  console at http://[hostname]:[port]/console    *

      ***************************************************

      <Sep 8, 2013 12:14:16 AM EDT> <Info> <Security> <BEA-090905> <Disabling CryptoJ

      JCE Provider self-integrity check for better startup performance. To enable this

      check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=true>

      <Sep 8, 2013 12:14:16 AM EDT> <Info> <Security> <BEA-090906> <Changing the defau

      lt Random Number Generator in RSA CryptoJ from ECDRBG to FIPS186PRNG. To disable

      this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true>

      <Sep 8, 2013 12:14:17 AM EDT> <Info> <WebLogicServer> <BEA-000377> <Starting Web

      Logic Server with Java HotSpot(TM) Client VM Version 19.1-b02 from Sun Microsyst

      ems Inc.>

      <Sep 8, 2013 12:14:18 AM EDT> <Info> <Security> <BEA-090065> <Getting boot ident

      ity from user.>

      Enter username to boot WebLogic server:weblogic

      Enter password to boot WebLogic server:

      <Sep 8, 2013 12:14:27 AM EDT> <Info> <Management> <BEA-141107> <Version: WebLogi

      c Server 10.3.5.0  Fri Apr 1 20:20:06 PDT 2011 1398638 >

      <Sep 8, 2013 12:14:28 AM EDT> <Info> <Management> <BEA-141223> <The server name

      soa_server1 specified with -Dweblogic.Name does not exist. The configuration inc

      ludes the following servers {AdminServer}.>

      <Sep 8, 2013 12:14:28 AM EDT> <Critical> <WebLogicServer> <BEA-000362> <Server f

      ailed. Reason:

       

       

      There are 1 nested errors:

       

       

      weblogic.management.ManagementException: [Management:141223]The server name soa_

      server1 specified with -Dweblogic.Name does not exist. The configuration include

      s the following servers {AdminServer}.

              at weblogic.management.provider.internal.RuntimeAccessImpl.<init>(Runtim

      eAccessImpl.java:149)

              at weblogic.management.provider.internal.RuntimeAccessService.start(Runt

      imeAccessService.java:41)

              at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesMan

      ager.java:461)

              at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServ

      icesManager.java:166)

              at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:881)

              at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:568)

              at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:469)

              at weblogic.Server.main(Server.java:71)

       

       

      >

      <Sep 8, 2013 12:14:28 AM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server sta

      te changed to FAILED>

      <Sep 8, 2013 12:14:28 AM EDT> <Error> <WebLogicServer> <BEA-000383> <A critical

      service failed. The server will shut itself down>

      <Sep 8, 2013 12:14:28 AM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server sta

      te changed to FORCE_SHUTTING_DOWN>

       

       

      C:\Oracle\Middleware\wlserver_10.3\common\bin> startManagedWebLogic.cmd soa_serv

      er1

       

       

      C:\Oracle\Middleware\wlserver_10.3\common\bin>echo off

      Need to set SERVER_NAME and ADMIN_URL environment variables or specify

      them in command line:

      Usage: startManagedWebLogic [SERVER_NAME] [ADMIN_URL]

      for example:

      startManagedWebLogic managedserver1 http://localhost:7001

       

       

      C:\Oracle\Middleware\wlserver_10.3\common\bin> startManagedWebLogic.cmd soa_serv

      er1 http://localhost:7001

       

       

      C:\Oracle\Middleware\wlserver_10.3\common\bin>echo off

       

       

      CLASSPATH=C:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\sys_manifest_classpa

      th\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_jdev1111\profiles\default\sys_man

      ifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\JDK160~1\lib\tools.jar;C:\

      Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;C:\Oracle\MIDDLE~1\WLSERV~

      1.3\server\lib\weblogic.jar;C:\Oracle\MIDDLE~1\modules\features\weblogic.server.

      modules_10.3.5.0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\webservices.jar;C:

      \Oracle\MIDDLE~1\modules\ORGAPA~1.1/lib/ant-all.jar;C:\Oracle\MIDDLE~1\modules\N

      ETSFA~1.0_1/lib/ant-contrib.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\common\derby\lib\d

      erbynet.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\common\derby\lib\derbyclient.jar;;C:\O

      racle\MIDDLE~1\JDK160~1\jre\lib\rt.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\

      webservices.jar;

       

       

      PATH=C:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\native;C:\Oracle\MIDDLE~1

      \patch_jdev1111\profiles\default\native;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\nat

      ive\win\32;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\bin;C:\Oracle\MIDDLE~1\modules\O

      RGAPA~1.1\bin;C:\Oracle\MIDDLE~1\JDK160~1\jre\bin;C:\Oracle\MIDDLE~1\JDK160~1\bi

      n;C:\product\11.2.0\dbhome_2\bin;C:\product\11.2.0\dbhome_1\bin;D:\app\Santosh\p

      roduct\11.2.0\dbhome_2\bin;C:\Program Files\Common Files\Microsoft Shared\Window

      s Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;D:\app\

      Santosh\product\11.2.0\dbhome_1\bin;C:\Windows\system32;C:\Windows;C:\Windows\Sy

      stem32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\W

      iFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files (x

      86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin

      \x64;C:\Program Files (x86)\Windows Live\Shared;D:\jdk\bin;C:\Program Files\Inte

      l\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Oracle\MIDDLE

      ~1\WLSERV~1.3\server\native\win\32\oci920_8

       

       

      ***************************************************

      *  To start WebLogic Server, use a username and   *

      *  password assigned to an admin-level user.  For *

      *  server administration, use the WebLogic Server *

      *  console at http://[hostname]:[port]/console    *

      ***************************************************

      <Sep 8, 2013 12:44:36 AM EDT> <Info> <Security> <BEA-090905> <Disabling CryptoJ

      JCE Provider self-integrity check for better startup performance. To enable this

      check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=true>

      <Sep 8, 2013 12:44:36 AM EDT> <Info> <Security> <BEA-090906> <Changing the defau

      lt Random Number Generator in RSA CryptoJ from ECDRBG to FIPS186PRNG. To disable

      this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true>

      <Sep 8, 2013 12:44:37 AM EDT> <Info> <WebLogicServer> <BEA-000377> <Starting Web

      Logic Server with Java HotSpot(TM) Client VM Version 19.1-b02 from Sun Microsyst

      ems Inc.>

      <Sep 8, 2013 12:44:38 AM EDT> <Info> <Security> <BEA-090065> <Getting boot ident

      ity from user.>

      Enter username to boot WebLogic server:weblogic

      Enter password to boot WebLogic server:

      <Sep 8, 2013 12:44:47 AM EDT> <Info> <Management> <BEA-141107> <Version: WebLogi

      c Server 10.3.5.0  Fri Apr 1 20:20:06 PDT 2011 1398638 >

      <Sep 8, 2013 12:44:48 AM EDT> <Info> <Management> <BEA-141223> <The server name

      soa_server1 specified with -Dweblogic.Name does not exist. The configuration inc

      ludes the following servers {AdminServer}.>

      <Sep 8, 2013 12:44:48 AM EDT> <Critical> <WebLogicServer> <BEA-000362> <Server f

      ailed. Reason:

       

       

      There are 1 nested errors:

       

       

      weblogic.management.ManagementException: [Management:141223]The server name soa_

      server1 specified with -Dweblogic.Name does not exist. The configuration include

      s the following servers {AdminServer}.

              at weblogic.management.provider.internal.RuntimeAccessImpl.<init>(Runtim

      eAccessImpl.java:149)

              at weblogic.management.provider.internal.RuntimeAccessService.start(Runt

      imeAccessService.java:41)

              at weblogic.t3.srvr.ServerServicesManager.startService(ServerServicesMan

      ager.java:461)

              at weblogic.t3.srvr.ServerServicesManager.startInStandbyState(ServerServ

      icesManager.java:166)

              at weblogic.t3.srvr.T3Srvr.initializeStandby(T3Srvr.java:881)

              at weblogic.t3.srvr.T3Srvr.startup(T3Srvr.java:568)

              at weblogic.t3.srvr.T3Srvr.run(T3Srvr.java:469)

              at weblogic.Server.main(Server.java:71)

       

       

      >

      <Sep 8, 2013 12:44:48 AM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server sta

      te changed to FAILED>

      <Sep 8, 2013 12:44:48 AM EDT> <Error> <WebLogicServer> <BEA-000383> <A critical

      service failed. The server will shut itself down>

      <Sep 8, 2013 12:44:48 AM EDT> <Notice> <WebLogicServer> <BEA-000365> <Server sta

      te changed to FORCE_SHUTTING_DOWN>

       

      Thanks,

      Santosh

        • 1. Re: SOA Server doesn't start
          togotutor

          When configuring the domain, which option did you choose? did you choose first option like Developers domain, then you just start AdminServer and you are all set. There is no soa_server1 and hence there is nothing to start. After admin server is started, login into em console and you should see all the soa modules deployed to admin server. Also, from the logs:

          weblogic.management.ManagementException: [Management:141223]The server name soa_server1 specified with -Dweblogic.Name does not exist. The configuration includes the following servers {AdminServer}.