2 Replies Latest reply: Sep 11, 2013 6:50 PM by 965674 RSS

    Dimension build error

    965674

      Hi Team,

      I am creating a dimension build rule file in EPM 11.1.2.2 and when i validate the rule file , I am getting the following error for Field1 and field2. Below is the outline

       

      Outline: PFI_ANA (Active Alias Table:Default)

      |- Accounts Accounts (Two Pass)

      |- Div ( Dynamic Calc)

      |- Bus ( Dynamic Calc)

      |-PF (Alias:example)

      |- Prod ( Dynamic Calc)

      |- Operation ( Dynamic Calc)

      |- Year Time  ( Label only)

      |- Type ( Dynamic Calc)

      |- System ( Dynamic Calc) {Number, Country}

      |- Number Attribute ( Type: Text)

      |- Country Attribute ( Type: Text)

       

      ERROR

      "The field type for this field is not valid for the build method associated with this field's dimension"

       

      I have setup field 1 as Parent and field 2 as child. Also In the load rule options Under Dimension build settings > Dimension Build settings tab even though I select the dimension that I am building "System" but its not getting retained and its always displaying "Accounts" dimensions.


      I also tried selecting parent/child build method but still I am getting the ERROR.


      I appreciate your input.



        • 1. Re: Dimension build error
          TimG

          You have basically the right idea... ...select 'System' (by double-clicking), then check 'Use parent/child references'.  Then click 'OK'.  It doesn't matter that the display defaults to another dimension when you open it up again - a single rule can remember the settings for multiple dimensions, and if you re-select 'System' you should see 'Use parent/child references' still checked.

           

          If you literally can't select 'System' (i.e. the selected dimension never changes) then it sounds like EAS is misbehaving and I suspect a Java compatibility issue whenever that happens.

          • 2. Re: Dimension build error
            965674

            Thanks for you input Tim.