This discussion is archived
5 Replies Latest reply: Sep 21, 2013 6:06 AM by 946778 Branched from an earlier discussion. RSS

forms 11g installation

946778 Newbie
Currently Being Moderated

Hi.

 

I'm getting the problem at the same place means at the point of Domain creation. It is taking much time and ending up with error message.

 

I'm using the right version of Web Logic server for Forms 11gR2.

OS - window-7 (32bit)

 

Below is the end part of the log file...

===================================

Creating a new AdminServer Object ...

  AdminServer port is 7001

  Starting the domain ...

  DEBUG : Loading the 32 bit dll here

    DEBUG : Loading DLL : C:/Oracle/Middleware/Oracle_FRHome1/install/config/StartUtil.dll

    DEBUG : Loaded DLL : C:/Oracle/Middleware/Oracle_FRHome1/install/config/StartUtil.dll

 

  Starting NodeManager

  DEBUG : Node Manager Prop File : C:/Oracle/Middleware/wlserver_10.3/common/nodemanager/nodemanager.properties

 

 

CLASSPATH=C:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_oepe1050\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_ocp360\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\JROCKI~1.2-4\lib\tools.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.jar;C:\Oracle\MIDDLE~1\modules\features\weblogic.server.modules_10.3.5.0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\webservices.jar;C:\Oracle\MIDDLE~1\modules\ORGAPA~1.1/lib/ant-all.jar;C:\Oracle\MIDDLE~1\modules\NETSFA~1.0_1/lib/ant-contrib.jar;

 

 

PATH=C:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\native;C:\Oracle\MIDDLE~1\patch_oepe1050\profiles\default\native;C:\Oracle\MIDDLE~1\patch_ocp360\profiles\default\native;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\native\win\32;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\bin;C:\Oracle\MIDDLE~1\modules\ORGAPA~1.1\bin;C:\Oracle\MIDDLE~1\JROCKI~1.2-4\jre\bin;C:\Oracle\MIDDLE~1\JROCKI~1.2-4\bin;C:\Oracle\Middleware\Oracle_FRHome1\bin;C:\app\VIKAS\product\11.2.0\dbhome_1\bin;C:\Middleware\Oracle_FRHome2\bin;C:\Middleware\Oracle_FRHome1\bin;C:\oraclexe\app\oracle\product\11.2.0\server\bin;C:\Oracle\DevSuiteHome3\jdk\jre\bin\classic;C:\Oracle\DevSuiteHome3\jdk\jre\bin;C:\Oracle\DevSuiteHome3\jdk\jre\bin\client;C:\Oracle\DevSuiteHome3\jlib;C:\Oracle\DevSuiteHome3\bin;C:\Oracle\DevSuiteHome3\jre\1.4.2\bin\client;C:\Oracle\DevSuiteHome3\jre\1.4.2\bin;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Middleware\Oracle_FRHome1\opmn\bin;C:\Middleware\Oracle_FRHome1\opmn\lib;C:\Middleware\Oracle_FRHome1\perl\bin;C:\Middleware\Oracle_FRHome2\opmn\bin;C:\Middleware\Oracle_FRHome2\opmn\lib;C:\Middleware\Oracle_FRHome2\perl\bin;C:\SQLITE;C:\Oracle\Middleware\Oracle_FRHome1\opmn\bin;C:\Oracle\Middleware\Oracle_FRHome1\opmn\lib;C:\Oracle\Middleware\Oracle_FRHome1\perl\bin;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\native\win\32\oci920_8

 

 

Your environment has been set.

 

 

CLASSPATH=C:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_oepe1050\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_ocp360\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\JROCKI~1.2-4\lib\tools.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.jar;C:\Oracle\MIDDLE~1\modules\features\weblogic.server.modules_10.3.5.0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\webservices.jar;C:\Oracle\MIDDLE~1\modules\ORGAPA~1.1/lib/ant-all.jar;C:\Oracle\MIDDLE~1\modules\NETSFA~1.0_1/lib/ant-contrib.jar;;C:\Oracle\MIDDLE~1\utils\config\10.3\config-launch.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\common\derby\lib\derbynet.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\common\derby\lib\derbyclient.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\common\derby\lib\derbytools.jar;;

 

 

Initializing WebLogic Scripting Tool (WLST) ...

 

 

Welcome to WebLogic Server Administration Scripting Shell

 

 

Type help() for help on available commands

 

 

Launching NodeManager ...

Properties: {ListenPort=5556,NativeVersionEnabled=true,NodeManagerHome=C:/Oracle/Middleware/wlserver_10.3/common/nodemanager,StartScriptEnabled=true,}

Command: C:\Oracle\MIDDLE~1\JROCKI~1.2-4\jre\bin\javaw.exe -classpath "C:\Oracle\MIDDLE~1\JROCKI~1.2-4\jre\lib\rt.jar;C:\Oracle\MIDDLE~1\JROCKI~1.2-4\jre\lib\i18n.jar;C:\Oracle\MIDDLE~1\patch_wls1035\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_oepe1050\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\patch_ocp360\profiles\default\sys_manifest_classpath\weblogic_patch.jar;C:\Oracle\MIDDLE~1\JROCKI~1.2-4\lib\tools.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic_sp.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.jar;C:\Oracle\MIDDLE~1\modules\features\weblogic.server.modules_10.3.5.0.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\webservices.jar;C:\Oracle\MIDDLE~1\modules\ORGAPA~1.1\lib\ant-all.jar;C:\Oracle\MIDDLE~1\modules\NETSFA~1.0_1\lib\ant-contrib.jar;C:\Oracle\MIDDLE~1\utils\config\10.3\config-launch.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\common\derby\lib\derbynet.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\common\derby\lib\derbyclient.jar;C:\Oracle\MIDDLE~1\WLSERV~1.3\common\derby\lib\derbytools.jar" weblogic.NodeManager "-v"

NMProcess: <15 Sep, 2013 8:37:19 PM> <INFO> <Loading domains file: C:\Oracle\Middleware\wlserver_10.3\common\nodemanager\nodemanager.domains>

NMProcess: 15 Sep, 2013 8:37:19 PM weblogic.nodemanager.server.NMServerConfig initDomainsMap

NMProcess: INFO: Loading domains file: C:\Oracle\Middleware\wlserver_10.3\common\nodemanager\nodemanager.domains

NMProcess: <15 Sep, 2013 8:37:23 PM> <INFO> <Loading identity key store: FileName=C:/Oracle/MIDDLE~1/WLSERV~1.3/server\lib\DemoIdentity.jks, Type=jks, PassPhraseUsed=true>

NMProcess: 15 Sep, 2013 8:37:23 PM weblogic.nodemanager.server.SSLConfig loadKeyStoreConfig

NMProcess: INFO: Loading identity key store: FileName=C:/Oracle/MIDDLE~1/WLSERV~1.3/server\lib\DemoIdentity.jks, Type=jks, PassPhraseUsed=true

NMProcess: <15 Sep, 2013 8:37:23 PM> <WARNING> <Node manager configuration properties file 'C:\Oracle\Middleware\wlserver_10.3\common\nodemanager\nodemanager.properties' not found. Using default settings.>

NMProcess: 15 Sep, 2013 8:37:23 PM weblogic.nodemanager.server.NMServer <init>

NMProcess: WARNING: Node manager configuration properties file 'C:\Oracle\Middleware\wlserver_10.3\common\nodemanager\nodemanager.properties' not found. Using default settings.

NMProcess: <15 Sep, 2013 8:37:23 PM> <INFO> <Saving node manager configuration properties to 'C:\Oracle\Middleware\wlserver_10.3\common\nodemanager\nodemanager.properties'>

NMProcess: 15 Sep, 2013 8:37:23 PM weblogic.nodemanager.server.NMServer <init>

NMProcess: INFO: Saving node manager configuration properties to 'C:\Oracle\Middleware\wlserver_10.3\common\nodemanager\nodemanager.properties'

NMProcess: <15 Sep, 2013 8:37:23 PM> <SEVERE> <Fatal error in node manager server>

NMProcess: java.lang.NullPointerException

NMProcess: at java.util.Hashtable.containsKey(Hashtable.java:314)

NMProcess: at weblogic.nodemanager.server.NMServerConfig.initNetworkInfoList(NMServerConfig.java:491)

NMProcess: at weblogic.nodemanager.server.NMServerConfig.getNetworkInfoList(NMServerConfig.java:481)

NMProcess: at weblogic.nodemanager.server.NMServerConfig.getConfigProperties(NMServerConfig.java:545)

NMProcess: at weblogic.nodemanager.server.NMServer.<init>(NMServer.java:154)

NMProcess: at weblogic.nodemanager.server.NMServer.main(NMServer.java:375)

NMProcess: at weblogic.NodeManager.main(NodeManager.java:31)

NMProcess:

NMProcess: 15 Sep, 2013 8:37:23 PM weblogic.nodemanager.server.NMServer main

NMProcess: SEVERE: Fatal error in node manager server

NMProcess: java.lang.NullPointerException

NMProcess: at java.util.Hashtable.containsKey(Hashtable.java:314)

NMProcess: at weblogic.nodemanager.server.NMServerConfig.initNetworkInfoList(NMServerConfig.java:491)

NMProcess: at weblogic.nodemanager.server.NMServerConfig.getNetworkInfoList(NMServerConfig.java:481)

NMProcess: at weblogic.nodemanager.server.NMServerConfig.getConfigProperties(NMServerConfig.java:545)

NMProcess: at weblogic.nodemanager.server.NMServer.<init>(NMServer.java:154)

NMProcess: at weblogic.nodemanager.server.NMServer.main(NMServer.java:375)

NMProcess: at weblogic.NodeManager.main(NodeManager.java:31)

NMProcess: Stopped draining NMProcess

NMProcess: Stopped draining NMProcess

Successfully launched the Node Manager.

The Node Manager process is running independent of the WLST process.

Exiting WLST will not stop the Node Manager process. Please refer

to the Node Manager logs for more information.

The Node Manager logs will be under C:\Oracle\Middleware\wlserver_10.3\common\nodemanager

Node Manager starting in the background.

======================================

 

Please suggest me what to do regarding this issue..I'm not able to understand where is the loophole.

Thanks in Advance..

  • 1. Re: forms 11g installation
    Su.gi Newbie
    Currently Being Moderated

    Hi, for installing oracle 11g forms and reports verify the below link

     

    Installing and Configuring Oracle Forms and Reports - 11g Release 2 (11.1.2)

     

    Hope this will help

  • 2. Re: forms 11g installation
    946778 Newbie
    Currently Being Moderated

    Thanks a lot for your reply..

     

    May be the problem in Node Manager is  not stopping..

    I have included the Node Manager listener port in the Node Manager Property file.

     

    But How to know whether the Node Manager is stopped or It is running. And how to kill the process of Node Manager, If it is running.

     

    Please suggest me..

     

    Thanks in advance..

  • 3. Re: forms 11g installation
    lake Journeyer
    Currently Being Moderated

    Look in services to see if you have process with the word node manager in it.  in which case you can hit the

    dark square box to stop it. how to find services depends on exactly what version of windows this is.

  • 4. Re: forms 11g installation
    Soofi Explorer
    Currently Being Moderated

    Hi,

     

    The Problem is with Node manager, Usually Node manager is to be stopped while installing...Check it after stopping

     

    If Problem persists let me know

     

    Regards,

    Soofi

  • 5. Re: forms 11g installation
    946778 Newbie
    Currently Being Moderated

    Hi Soofi,

     

    I have followed the below steps :-  ( from Oracle user guide)

     

    2.2.4 Stopping Node Manager Before Installing Oracle Forms and Reports (Windows Only)

    If you are installing Oracle Forms and Reports on a Microsoft Windows operating system, you must make sure that the Node Manager utility that was installed with Oracle WebLogic Server is stopped before you begin the installation:

    1. Verify the Oracle WebLogic Server Node Manager utility is stopped. If it is running, kill the process.

                    For this step i used nmdisconnect() command in weblogic command prompt and also got the message that Node manager stopped.

     

    1. Determine if the nodemanager.properties file is present in the WebLogic_Home\common\nodemanager directory.
      1. If the nodemanager.properties file is not present, continue installing Oracle Forms and Reports.
      2. If the nodemanager.properties file does exist, open it and verify that the ListenPort parameter is included and that it is set. If the ListenPort parameter is not included or set, edit the nodemanager.properties file so that it is similar to the following, where NODE_MANAGER_LISTEN_PORT represents the port the Node Manager listens on, such as 5556:ListenPort=NODE_MANAGER_LISTEN_PORT.

        

                for this step, Node manager properties file was not present in the respective folder, so i have created a .properties file and included                                                                                                                                    ListenPort=NODE_MANAGER_LISTEN_PORT


    after all these steps I have clicked on "Configure Classic Instance" from start Menu ( Note - I didn't install the complete forms and reports again from scratch). I just configured again .But again i faced the same problem and same log message as above came in the out file.


    Please suggest as what to do for this.


    Thanks in Advance.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points