5 Replies Latest reply: Dec 17, 2013 7:22 PM by User598465-OC RSS

    P6 R8.3 Problems with BI Publisher, Team Member

    rjebb

      Hi

       

      I am setting up a demo server with P6 R8.3 EPPM. The process I have followed so far is:

       

      Install Windows Server 2008 R2 SP1 on the box (2 x Quad Core Xeon, 16GB RAM, 2 x 300GB drives)

      Install SQL Server 2005 and copy across our current demo R8.2 EPPM database

      Install JDK 1.6.0_41 64 bit

      Upgrade the database to R8.3

      Create a new Middleware Repository for BIP

      Do a "simple install" of 64bit BIP from the "generic" distro to create an instance of WebLogic 10.3 and BIP 11.0.0.6.0 within it

      Install P6 R8.3 and configure it to deploy into the existing WebLogic instance

      Copy the P6 Reports into BIP and set up BIP as per the docs

       

      I had to use the db configuration tool to create (?overwrite) the old P6 Configuration data in the database as when using the web P6 Administrator it was telling me that no database was configured for administration, and I have then gone in to adjust the URL for the database and the link to BI Publisher.

       

      The supported configurations document also says that a patch needs to be applied to WebLogic 11g and I have tried applying it but it seems to be ignoring it - an earlier build attempt using a 32 bit version of WebLogic installed separately from BIP did take the patch, so maybe there is a later version of WebLogic bundled with BIP?... In any case, I am not seeing the error the patch was released to fix.

       

      As of now, I have a working P6 environment with all data carried over from the 8.2 environment. There are 2 odd things happening though, and I can't see any reason for them:

       

      First, any user trying to access Team Member Web Services gets an error message at login saying they are configured to use Progress Reporter to update progress. This happens regardless of the Module Access settings for that user, it just doesn't seem to work any more. Is there more I have to do here?

       

      Second, I can't get the reports tab in EPPM to work, and always get the error message saying that the user is not configured in BI Publisher. Just to be clear what I have done:

       

      I followed the procedure in the docs for setting up P6 reports in BIP and have checked it numerous times.

      BIP is using the BIP Security model with a local superuser

      The JDBC connection to the P6 database works, and I can login as any of the users in BIP that I set up to match the P6 users, and execute reports within BIP and see results returned

      Those P6 users have got Enterprise Reporting module access

      I have bounced both P6 and BIP several times within WebLogic, and WebLogic is showing all the various subsystems are running OK (as is Enterprise Manager)

       

      I have compared the setup of this version of BI and P6 to those in our working R8.2 system, and the only 2 differences I can see are

       

      BI is 11.0.0.5.0  for R8.2 and 11.0.0.6.0 for R8.3

      When I assigned the data model to the reports in R8.3, the icon for the report disappeared and now just displays as a black box with an x in - but it only did this for some reports (eg the Activity ones)

       

      One thing I am not clear on is the format of the URL for the BI web services - some docs say it should end in ?WSDL, others don't (for the combination of BIP 11g and SQl Server). I have tried both forms without seeing any change in behaviour (Typing either form into a browser results in a response so the web services system is definitely alive).. I have also tried changing the path to the reports from "/P6Reports" (which it actually is) to "/P6REPORTS" (which works in our R8.2 system, even though that's not what the folder is named - its also /P6Reports), but again that doesn't make any difference. Finally, I have tried logging into BIP directly using the credentials saved in the configuration and they work fine.

       

      I am completely stumped - can anyone offer any further things to try out?

        • 1. Re: P6 R8.3 Problems with BI Publisher, Team Member
          algibson

          Hi,

           

          Sounds like you have everything pretty much correct so the following are just some best guesses/suggestions/.

           

          TeamMember - can you try creating a new user with TM Module access. I'm wondering if the user you are testing with has logged into PR in the past it might somehow be tied to PR (if a new user does log in then you could try resetting the user preferences to see if it helps the existing user accounts).

           

          For BIP the only thing that stands out is the BI Version, i've been installing 11.1.1.5 / 11.1.1.6 (or even 11.1.1.7). I don't know if this value has much impact on anything to be honest but probably worth making sure you have one of these versions (not sure if 11.0.0.x even exists)

          I've generally found the ?WSDL isn't actually needed in any install i've done (either on Oracle DB or SQL).

          I'd suggest try putting in the password again, and possibly resetting it in BI given when you create the password there is no confirmation.

           

          Failing that you could try changing the logging level to see if it highlights the cause.

           

           

          Regards

          Alex

          • 2. Re: P6 R8.3 Problems with BI Publisher, Team Member
            rjebb

            Alex

             

            Thanks for your thoughts. I have got the BIP version wrong, it is 11.1.1.6.0 for what its worth

             

            Where do you adjust the logging level for the various bits of EPPM/BI, and where do the resulting logs end up? Any ideas?

             

            I am resigned to submitting the original post to Oracle Support to see if they come up with anything, and if so I will add the results here.

             

            Richard

            • 3. Re: P6 R8.3 Problems with BI Publisher, Team Member
              algibson

              Hi Richard,

               

              The TeamMember one is definitely odd so i'd love to hear what Oracle support have to say.

               

              You should hopefully only have to look into the P6 logs, especially if the reports are running successfully in BI which means most of your config is good.

              I've hit this same problem dozens of times and there's usually one small thing missing or typo, etc. you can end up doing half the P6/BI config again until you find the problem.

               

              To change the logging level in the P6 Admin App go to your configuration and under Log->File Logger change the severity to Debug.

              Restart P6 and try the Reports tab again.

               

              Regards

              Alex

              • 4. Re: P6 R8.3 Problems with BI Publisher, Team Member
                rjebb

                Alex

                 

                I have finally had an answer from Oracle about the BI Publisher issue, which is due to the fact that I installed the WebLogic bundled inside the Oracle Business Intelligence media set which is 10.3.5, while P6 R8.3 requires 10.3.6

                 

                So for the products to share an instance of WebLogic that both can use, you have to install WebLogic first from its own media set and without creating any domains. Then you patch it as specified in the Supported Configurations document, then install BI Publisher using the "Software Only" option, deploy that into a new domain, and finally install/deploy P6 into its own domain.

                 

                I now can see the reports in P6, but running them within P6 is producing an error. The Team Member issue is still partly there - assigning Team Member access to a user who didn't previously have it seems to work, but those who had it in 8.2 still can't login as the system still thinks they are set up for Progress Reporter. We have also encountered a problem where the whole top half of the user interface - the main tabs and the menu in the top RH corner - all is grayed out and becomes inactive at various points. I have found this listed as a bug related to Java 7 in the client browser which is fixed in R8.3 SP1 so I am now going to try to install that across all the various components of the product and see what happens...

                • 5. Re: P6 R8.3 Problems with BI Publisher, Team Member
                  User598465-OC

                  Don't know if you ever got it working, ..., but

                  For Team Member

                  1. Make sure that the user has module access.  Navigate to User Access from Administer.  Select the user, in the Module Access tab at the bottom, make sure Team Member Interfaces is checked.

                  2. Make sure timesheets are not enabled for the user.   Navigate to Resources->Administration->Resources tab.  Select the resource associated with the user, then make sure in the Settings tab at the bottom that Uses Timesheets is not checked in the Progress Reporter section

                  For OBI Publisher issue

                  1. Make sure that the URL configured in the P6 Admin Tool is set to something like http://[server:port]/xmlpserver/services/PublicReportService?WSDL

                   

                  I have just gone through all of this, so hope this helps if you haven't already got it resolved.