5 Replies Latest reply: Sep 27, 2013 7:03 AM by RJG RSS

    Start EM(Enterprise Manager) with AdminServer(WebLogic) in services  Windows

    RJG

      hi,

      I have installed

      WebLogic Server 1036 and Forms/Reports 11GR2

       

      Installed WebLogic (AdminServer) to start with Windows Services!

      It starts with Windows and open localhost: 7001/console 'successfully

       

      echo off
      SETLOCAL
       set DOMAIN_NAME=FormsDomain
       set USERDOMAIN_HOME=C:\Oracle\Middleware\user_projects\domains\FormsDomain
       set SERVER_NAME=AdminServer
       set PRODUCTION_MODE=true
       set WLS_USER=weblogic
       set WLS_PW=weblogic1
       call C:\Oracle\Middleware\wlserver_10.3\server\bin\installSvc.cmd
      ENDLOCAL
      

       

       

      Everything ok so far!

      However, I can not EM (Enterprise Manager) "localhost: 7001/em '

      When I start the Server Admin Menu> Windows \ Start Menu \ Programs \ Oracle Classic Instance - FormsInst> Start Weblogic Server Admin

      I can get 'localhost: 7001/em' usually

       

      Can anyone give me an idea?

        • 1. Re: Start EM(Enterprise Manager) with AdminServer(WebLogic) in services  Windows
          ngsankar

          Check the 'em.war' deployment status from WLS Admin console, try to start install and start the em again if the status is not preprared mode

          • 2. Re: Start EM(Enterprise Manager) with AdminServer(WebLogic) in services  Windows
            RJG

            hello,

            Thanks for answering!

            Look at these pictures EM start, but in Admin mode

            i do not know what is the problem:

            con1_zps3bfb8663.jpg Photo by roneigodinho | Photobucket

            con2_zps6cac9ff1.jpg Photo by roneigodinho | Photobucket

            sorry the language of images (Portuguese Brazil)

             

            this occurs only when it is started by the Windows service!

            • 3. Re: Start EM(Enterprise Manager) with AdminServer(WebLogic) in services  Windows
              RJG

              can someone help me?

              checking the log returns this error!

              ####<25/09/2013 14h27min39s BRT> <Warning> <Munger> <RONEI> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <c45a6d0f723d9f21:-3dd7bb09:1415629670e:-8000-0000000000000002> <1380130059591> <BEA-2156203> <A version attribute was not found in element application in the deployment descriptor in C:\Oracle\Middleware\user_projects\applications\FormsDomain\em.ear/META-INF/application.xml. A version attribute is required, but this version of the Weblogic Server will assume that the JEE5 is used. Future versions of the Weblogic Server will reject descriptors that do not specify the JEE version.>

              ####<25/09/2013 14h27min39s BRT> <Error> <Deployer> <RONEI> <AdminServer> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <c45a6d0f723d9f21:-3dd7bb09:1415629670e:-8000-0000000000000002> <1380130059671> <BEA-149205> <Failed to initialize the application 'em' due to error weblogic.management.DeploymentException: .

              weblogic.management.DeploymentException:

                at weblogic.application.internal.flow.BaseLifecycleFlow$CreateListenerAction.run(BaseLifecycleFlow.java:176)

                at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)

                at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)

                at weblogic.application.internal.flow.BaseLifecycleFlow$BaseAction.invoke(BaseLifecycleFlow.java:104)

                at weblogic.application.internal.flow.HeadLifecycleFlow.createListener(HeadLifecycleFlow.java:117)

                at weblogic.application.internal.flow.HeadLifecycleFlow.createListener(HeadLifecycleFlow.java:103)

                at weblogic.application.internal.flow.HeadLifecycleFlow.createListeners(HeadLifecycleFlow.java:175)

                at weblogic.application.internal.flow.HeadLifecycleFlow.prepare(HeadLifecycleFlow.java:281)

                at weblogic.application.internal.BaseDeployment$1.next(BaseDeployment.java:648)

                at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

                at weblogic.application.internal.BaseDeployment.prepare(BaseDeployment.java:191)

                at weblogic.application.internal.EarDeployment.prepare(EarDeployment.java:59)

                at weblogic.application.internal.DeploymentStateChecker.prepare(DeploymentStateChecker.java:154)

                at weblogic.deploy.internal.targetserver.AppContainerInvoker.prepare(AppContainerInvoker.java:60)

                at weblogic.deploy.internal.targetserver.AppDeployment.prepare(AppDeployment.java:144)

                at weblogic.management.deploy.internal.DeploymentAdapter$1.doPrepare(DeploymentAdapter.java:39)

                at weblogic.management.deploy.internal.DeploymentAdapter.prepare(DeploymentAdapter.java:191)

                at weblogic.management.deploy.internal.AppTransition$1.transitionApp(AppTransition.java:21)

                at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:240)

                at weblogic.management.deploy.internal.ConfiguredDeployments.prepare(ConfiguredDeployments.java:165)

                at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:122)

                at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:180)

                at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:96)

                at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)

                at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)

                at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)

              Caused By: java.lang.ClassNotFoundException: oracle.security.jps.wls.listeners.JpsApplicationLifecycleListener

                at weblogic.utils.classloaders.GenericClassLoader.findLocalClass(GenericClassLoader.java:297)

                at weblogic.utils.classloaders.GenericClassLoader.findClass(GenericClassLoader.java:270)

                at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

                at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

                at weblogic.utils.classloaders.GenericClassLoader.loadClass(GenericClassLoader.java:179)

                at java.lang.Class.forName0(Native Method)

                at java.lang.Class.forName(Class.java:247)

                at weblogic.application.internal.flow.BaseLifecycleFlow$CreateListenerAction.run(BaseLifecycleFlow.java:140)

                at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)

                at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)

                at weblogic.application.internal.flow.BaseLifecycleFlow$BaseAction.invoke(BaseLifecycleFlow.java:108)

                at weblogic.application.internal.flow.HeadLifecycleFlow.createListener(HeadLifecycleFlow.java:117)

                at weblogic.application.internal.flow.HeadLifecycleFlow.createListener(HeadLifecycleFlow.java:103)

                at weblogic.application.internal.flow.HeadLifecycleFlow.createListeners(HeadLifecycleFlow.java:175)

                at weblogic.application.internal.flow.HeadLifecycleFlow.prepare(HeadLifecycleFlow.java:281)

                at weblogic.application.internal.BaseDeployment$1.next(BaseDeployment.java:649)

                at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

                at weblogic.application.internal.BaseDeployment.prepare(BaseDeployment.java:191)

                at weblogic.application.internal.EarDeployment.prepare(EarDeployment.java:59)

                at weblogic.application.internal.DeploymentStateChecker.prepare(DeploymentStateChecker.java:154)

                at weblogic.deploy.internal.targetserver.AppContainerInvoker.prepare(AppContainerInvoker.java:60)

                at weblogic.deploy.internal.targetserver.AppDeployment.prepare(AppDeployment.java:144)

                at weblogic.management.deploy.internal.DeploymentAdapter$1.doPrepare(DeploymentAdapter.java:40)

                at weblogic.management.deploy.internal.DeploymentAdapter.prepare(DeploymentAdapter.java:191)

                at weblogic.management.deploy.internal.AppTransition$1.transitionApp(AppTransition.java:22)

                at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:240)

                at weblogic.management.deploy.internal.ConfiguredDeployments.prepare(ConfiguredDeployments.java:166)

                at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:122)

                at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:181)

                at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:97)

                at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)

                at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)

                at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)

              • 4. Re: Start EM(Enterprise Manager) with AdminServer(WebLogic) in services  Windows
                Rosario

                Hi,

                 

                Problem is with the classpath settings. Try calling setDomainEnv.cmd before installsvc.cmd.

                 

                Another way is to start adminserver via commandline(using startWeblogic.cmd), then copy all the classpath entries into a text file<<classpath.txt>>.

                Then while installing the service try using the file using -classpath @<<classpath.txt>> attribute.

                 

                You can find more information about in the below link for using classpath.txt file.

                 

                Setting Up a WebLogic Server Instance as a Windows Service

                 

                Regards

                Rosario

                • 5. Re: Start EM(Enterprise Manager) with AdminServer(WebLogic) in services  Windows
                  RJG

                  hi Rosario,

                  really ... I did another installation service calling setDomainEnv.cmd.

                   

                  echo off
                  SETLOCAL
                   set DOMAIN_NAME=FormsDomain
                   set USERDOMAIN_HOME=C:\Oracle\Middleware\user_projects\domains\FormsDomain
                   set SERVER_NAME=AdminServer
                   set PRODUCTION_MODE=true
                   set WLS_USER=weblogic
                   set WLS_PW=weblogic1
                   cd %USERDOMAIN_HOME%
                   call %USERDOMAIN_HOME%\bin\setDomainEnv.cmd
                   call C:\Oracle\Middleware\wlserver_10.3\server\bin\installSvc.cmd
                  ENDLOCAL
                  

                   

                  and it worked perfectly!

                  thank you Hugs