7 Replies Latest reply: Sep 26, 2013 11:26 PM by JDeveloper Newbie (11.1.1.6.0) RSS

    Unable to run JSPX page

    JDeveloper Newbie (11.1.1.6.0)

      Hi everyone,

       

      First, please forgive me if my terminology is incorrect; I am a newbie with JDeveloper.

       

      When I try to run the JSPX page, the browser cannot connect. (Should I be saying "deploy" instead of "run" in this case?) Everything works (navigating, committing, updating, deleting) when I use the Business Components Browser. Therefore, I am pretty sure it is VPN related, and a configuration change is probably in order on the WebLogic Server. However, I cannot even connect to the console (http://127.0.0.1:7101/console). In JDeveloper Preferences, everything under the Web Browser and Proxy seems to be configured correctly as the Test Proxy is successful, and as mentioned, I have no problem communicating with the DB.


      This is the target URL that fails: http://127.0.0.1:7101/XXJL-ViewController-context-root/faces/myFirstPage.jspx.


      Any help would be appreciated.

       

      James

        • 1. Re: Unable to run JSPX page
          Timo Hahn

          As you run the page on your local pc you should not have a proxy setting at all. The problem can be that the url is send to the proxy which naturally can't run it.

          'Uncheck the checkbox for hte proxy setting and try again.

           

          Timo

          • 2. Re: Unable to run JSPX page
            JDeveloper Newbie (11.1.1.6.0)

            Hi Timo,

             

            Thanks for responding; you helped me rule out one possibility. I disabled the proxy server in Windows Internet Options > LAN settings and in the JDeveloper Preferences > Web Browser and Proxy settings with no luck. I also tried the Preferences > Web Browser and Proxy settings in JDeveloper by itself. That did not work either.

             

            Maybe this is a clue. When I try the http://127.0.0.1:7101 address, it directs me to http://10.120.50.37 instead. It is probably a dynamically generated URL, but I am no networking expert and am not sure if that should be happening.


            From the log:

            [08:24:47 PM] The following URL context root(s) were defined and can be used as a starting point to test your application:

            [08:24:47 PM] http://10.120.50.37:7101/XXJL-ViewController-context-root

            Target URL -- http://127.0.0.1:7101/XXJL-ViewController-context-root/faces/myFirstPage.jspx

             

            A colleague suggested that I review the local domain configuration, but he does not remember where to do that. That is why I still want to get to the WebLogic Server console or at least find a configuration file to review.

             

            Other suggestions would be appreciated.

             

            Thanks.

             

            James

            • 3. Re: Unable to run JSPX page
              Timo Hahn

              Test if you can reach the administration console after you have started the application using the url 127.0.0.1:7101/console

              This should show the login page of the administration console. If you don't get it, you have a problem with your network configuration. 

               

              The second start url your see in the log is the one with your ip instead of the localhost.

               

              Timo

              • 4. Re: Unable to run JSPX page
                JDeveloper Newbie (11.1.1.6.0)

                Well...I forgot my WebLogic server password and re-installed JDeveloper. And, the same issue occurs.

                 

                http://localhost:7001/console/login/LoginForm.jsp works, and I am able to login.


                This was in the log; the bold IP address is the one that always ends up as the address when I try to deploy:
                <Sep 25, 2013 11:52:14 PM EDT> <Warning> <Server> <BEA-002611> <Hostname "JFL9008201.na.ops.local", maps to multiple IP addresses: 10.120.50.37, 192.168.1.14, 192.168.1.15, fe80:0:0:0:38dc:95a3:26b8:1698%22, fe80:0:0:0:d462:48f3:a6af:e8d%15, fe80:0:0:0:d00d:6f6:12cf:2132%17, fe80:0:0:0:0:5efe:a78:3225%35, fe80:0:0:0:0:5efe:c0a8:10e%36, fe80:0:0:0:0:5efe:c0a8:10f%36>


                The target is still the same:

                Target URL -- http://127.0.0.1:7101/XXJL-ViewController-context-root/faces/myFirstPage.jspx

                • 5. Re: Unable to run JSPX page
                  Sireesha Pinninti-Oracle

                  Hi,

                   

                  Your application URL refers port 7101 where as your Admin console refers 7001, are you using correct port in application URL?

                  If you referred port correct in Admin console url, then try with following URL:

                  http://127.0.0.1:7001/XXJL-ViewController-context-root/faces/myFirstPage.jspx

                   

                  Sireesha

                  • 6. Re: Unable to run JSPX page
                    Timo Hahn

                    Sireesha is right.If you run an application in hte integrated server, the admin server is used as deployment target too. The console and the application are using the same port in this case.

                    Please check the settings of the integrated server: application server navigator->integrated server ->properties and switch to the configuration tab. There you should see 127.0.0.1 as hostname and check the preferred port to be the one you use in the url (7001) in your case.

                    From your log message I conclude that you are running a VM on your pc too (192.168.1.14, 192.168.1.15). Check if you have configured the network to use NAT with port forwarding. If this is the case check if you forward the preferred port. If this is the case you should use another preferred port which you not forward.


                    Timo

                    • 7. Re: Unable to run JSPX page
                      JDeveloper Newbie (11.1.1.6.0)

                      Hi Sireesha and Timo,


                      The issue is resolved.

                       

                      These are the steps that resolved the issue:

                      1. Uninstalled and reinstalled JDeveloper. Normally this should not be necessary, but I forgot my WebLogic Server password and the articles and suggestions regarding password resets were not working for me.
                      2. During the Configure the Administration Server step in the Fusion Middleware Configuration Wizard, I kept the defaults except for my port:
                        • *Name: AdminServer
                        • *Listen address: All Local Addresses
                        • Listen port: 7001
                        • SSL listen port: N/A
                        • SLL enabled: Unchecked.
                      3. In the JDeveloper Configure Default Domain dialog, I entered the following:
                        • Administrator ID and Password used for the WebLogic Server.
                        • Listen Address: Blank
                          • This was my problem. The dropdown listed a few local addresses, and because I kept the "All Local Addresses" value in the *Listen address field during the step above, I thought I was covered. However, my jspx pages would not open in the browser.
                        • Listen port: 7001
                      4. Deleted the C:\Users\<Windows User>\AppData\Roaming\JDeveloper\<Middleware Home> folder. This was probably unnecessary, but it was one of the steps I took because it gave me a clean slate to start over.
                      5. Opened JDeveloper, and in the Configure Default Domain dialog, I entered the following:
                        • Administrator ID and Password used for the WebLogic Server.
                        • Listen Address: localhost
                        • Listen port: 7001


                      Thank you both for your time.

                       

                       


                      Sireesha, I wanted to mark your answer as helpful too but did not see a way to do it.


                      James