8 Replies Latest reply on Sep 30, 2013 3:09 PM by cj

    PHP provider for dtrace


      Hi, i am trying to play with Oracle Dtrace for Linux. I have installed Oracle Linux with beta UEK kernel (3.8.13-13.el6uek.x86_64) and dtrace packages/modules. To enable dtrace with PHP i compiled it from the source, with

      './configure' '--prefix=/usr/local/php54' '--enable-dtrace' '--with-apxs2' '--enable-mysqlnd' '--with-pdo-mysql' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--enable-fpm'


      configuration line. If i am running php from command line i can see dtrace probes. E.g. after starting /usr/local/php54/bin/php in the second window

      [root@oracle ~]# dtrace -l|grep php

        642    php2201               php               dtrace_compile_file compile-file-entry

        643    php2201               php               dtrace_compile_file compile-file-return

        644    php2201               php                        zend_error error

        645    php2201               php  ZEND_CATCH_SPEC_CONST_CV_HANDLER exception-caught

        646    php2201               php     zend_throw_exception_internal exception-thrown

        647    php2201               php                    dtrace_execute execute-entry

        648    php2201               php           dtrace_execute_internal execute-entry

        649    php2201               php                    dtrace_execute execute-return

        650    php2201               php           dtrace_execute_internal execute-return

        651    php2201               php                    dtrace_execute function-entry

        652    php2201               php                    dtrace_execute function-return

        653    php2201               php              php_request_shutdown request-shutdown

        654    php2201               php               php_request_startup request-startup


      But if i am starting it as apache module (mod_php) it does not work for some reason, i don`t see any dtrace probes in the list. Also i tried to use php-fpm (fastcgi) sapi but no luck as well. What i did to solve this:

      • Disabled selinux
      • Set 666 on all files in /dev/dtrace


      Unfortunately i am still not able to find dtrace probles in the list. Could you please help with this? This is virtual machine, and i can provide it if needed.