7 Replies Latest reply on Sep 27, 2013 2:45 PM by RomanD

    Unable to run 11g form

    RomanD

      Win: 7 (x64)

      IE:10

      Form Builder: 11.1.2.0.0

      Oracle db: 11.2.0.3.0

      JRE: 1.6

       

      Hello,

      I am trying to run a form locally and not able to do so. Not sure where I need to start troubleshooting.

      My Runtime -> Application Server URL is set to: http://RDOGADINLT7.hughes.com:7001/forms/frmservlet

      I am able to start Node Manager. It tells me "Plain socket listener started on port 5556".

      I am able to run startWebLogic.cmd and I get "<Server started in RUNNING mode>".

      I do have "127.0.0.1      localhost" added to my host file.

       

      portlist.ini file:

      OPMN_REMOTE_PORT=6701

      OPMN_LOCAL_PORT=6700

      OPMN_REQUEST_PORT=6702

      DOMAIN_PORT=7001

       

      default.env file:

      ORACLE_HOME=C:\Oracle\Middleware\Oracle_FRHome1

      ORACLE_INSTANCE=C:\Oracle\Middleware\asinst_1

      TNS_ADMIN=C:\Oracle\Middleware\asinst_1\config

      FORMS_PATH=C:\Oracle\Middleware\Oracle_FRHome1\forms;C:\Oracle\Middleware\asinst_1\FormsComponent\forms

      WEBUTIL_CONFIG=C:\Oracle\Middleware\asinst_1\config\FormsComponent\forms\server\webutil.cfg

      FORMS_RESTRICT_ENTER_QUERY=TRUE

      CLASSPATH=C:\Oracle\Middleware\Oracle_FRHome1\forms\j2ee\frmsrv.jar;C:\Oracle\Middleware\Oracle_FRHome1\jlib\ldapjclnt11.jar;C:\Oracle\Middleware\Oracle_FRHome1\jlib\debugger.jar;C:\Oracle\Middleware\Oracle_FRHome1\jlib\ewt3.jar;C:\Oracle\Middleware\Oracle_FRHome1\jlib\share.jar;C:\Oracle\Middleware\Oracle_FRHome1\jlib\utj.jar;C:\Oracle\Middleware\Oracle_FRHome1\jlib\zrclient.jar;C:\Oracle\Middleware\Oracle_FRHome1\reports\jlib\rwrun.jar;C:\Oracle\Middleware\Oracle_FRHome1\forms\java\frmwebutil.jar;C:\Oracle\Middleware\Oracle_FRHome1\jlib\start_dejvm.jar;C:\Oracle\Middleware\Oracle_FRHome1\opmn\lib\optic.jar

      PATH=C:\Oracle\Middleware\Oracle_FRHome1\bin;C:\Oracle\Middleware\Oracle_FRHome1\jdk\jre\bin\client;C:\Oracle\Middleware\Oracle_FRHome1\jdk\bin

      FORMS=C:\Oracle\Middleware\Oracle_FRHome1\forms

       

      forms.conf

      RewriteEngine on

      RewriteRule ^/forms/html/(..*) /workaroundhtml/$1 [PT]

      AliasMatch ^/workaroundhtml/(..*) "C:\Oracle\Middleware\asinst_1/config/FormsComponent/forms/html/$1"

      RewriteRule ^/forms/registry/(..*) /workaroundregistry/$1 [PT]

      AliasMatch ^/workaroundregistry/(..*) "C:/Oracle/Middleware/user_projects/domains/ClassicDomain/config/fmwconfig/servers/WLS_FORMS/applications/formsapp_11.1.2/config/forms/registry/$1"

       

      I did notice that the forms.conf file points at ClassicDomain directory, where the Web Logic server started as "mydomain", that I recently created. Do I need to repoint to mydomain instead?

       

      When I run a form I get the message below in my IE window:

       

      Error 404--Not Found

      From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:

      10.4.5 404 Not Found

      The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.

      If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.

       

      Can someone help me with this?

      Thanks in advance

      Roman