1 Reply Latest reply: Sep 27, 2013 11:03 AM by Mpalski RSS

    Setting Up JDeveloper for Asset Development




      I am having trouble connecting to my WebCenter environment from JDeveloper and cannot set up direct upload/download. I am following the instructions here: Developing Components for WebCenter Portal Using JDeveloper - 11g Release 1 (


      I am running a Linux Oracle(64bit) VM with WebCenter installed on it. When I run ifconfig in the VM I get these values:

      eth0     inet addr:     Bcast:     Mask:

      lo        inet addr:     Mask:


      My host file is set up like this:     webcenter.oracle.local


      I logged into the admin console and added weblogic the group 'Monitors'.


      Port forwarding for the VM is already set up - I can access all of the managed servers from my laptop's desktop at:




      However, I am not about to use WLST to connect to the admin server using:



      Can anyone help figure out why I cannot connect the managed servers on my VM?




        • 1. Re: Setting Up JDeveloper for Asset Development

          I tried connecting to a WebCenter instance that is not on a VM. I am able to connect but now I get this error:


          Problem invoking WLST - Traceback (innermost last):

            File "C:\Users\MPALSKI\AppData\Roaming\JDeveloper\system11.\o.webcenter.portal.\ResourceUpload.py", line 28, in ?

          NameError: importWebCenterResource


          That line of code reads like this:

          importWebCenterResource(appName=mAppName, fileName=mArchivePath, resourceType=mResourceType, spaceGUID=mScope, server=mServer)