0 Replies Latest reply: Oct 1, 2013 11:41 AM by Sumit Biswas RSS

    Error in running pack.sh

    Sumit Biswas

      I have installed WebLogic in 2 OEL x86_64 machines and JDK is JDK1.6.0_45. In Machine_1, I have created cluster domain which I want to pack and then unpack in Machine_2.


      But I am in a middle of weird problem. When I run below command to pack, I get no output even if I turn on the log, there is nothing written. Basically I get no jar file when I run pack.sh and it does nothing.


      ./pack.sh -domain=/scratch/gbucis/Oracle/Middleware/user_projects/domains/osm_cluster_domain -template=/scratch/gbucis/Oracle/Middleware/wlserver_10.3/common/bin/osm_cluster_domain_pack.jar -template_name="osm_cluster_domain_pack" -managed=true


      Later I ran the command that pack.sh internally executes (I am not sure if it is correct way to do, but I just gave a try). Note that I have substituted template name, desc and author.


      eval "${JAVA_HOME}/bin/java" -Dprod.props.file='/scratch/gbucis/Oracle/Middleware/wlserver_10.3/.product.properties' -Xms32m -Xmx200m -XX:MaxPermSize=128m com.oracle.cie.domain.script.Packer -domain='/scratch/gbucis/Oracle/Middleware/user_projects/domains/osm_cluster_domain' -template='/scratch/gbucis/Oracle/Middleware/wlserver_10.3/common/bin/osm_cluster_domain_pack.jar' -managed='true' -template_name="${TEMPLATE_NAME}" -template_desc="${TEMPLATE_DESC}" -template_author="${TEMPLATE_AUTHOR}"


      With above line, I get below error. I thought its a CLASSPATH problem, so ran setWLSEnv.sh and also added MW_HOME and WLS_HOME in PATH variable. But nothing solved the problem.


      Exception in thread "main" java.lang.NoClassDefFoundError: com/oracle/cie/domain/script/Packer

      Caused by: java.lang.ClassNotFoundException: com.oracle.cie.domain.script.Packer

              at java.net.URLClassLoader$1.run(URLClassLoader.java:202)

              at java.security.AccessController.doPrivileged(Native Method)

              at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

              at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

              at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

              at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

      Could not find the main class: com.oracle.cie.domain.script.Packer.  Program will exit.


      Can anybody please help me to solve this problem?


      Thanks in advance.

      Sumit Biswas