This discussion is archived
0 Replies Latest reply: Oct 1, 2013 3:53 PM by user10494329 RSS

ToDate and Ago

user10494329 Newbie
Currently Being Moderated

Thanks in advance to anyone who might respond.

I am on OBIEE 11.1.1.6.10 and this is a new project.

 

I have been having this issue and have not found it listed for anyone else.  I am using the ToDate Function with the Time Series that has a hierarchy set up and I believe it is set up correctly.  Each level below is only included in one area above.

 

Date - Month - Quarter - Year.

 

The problem is not consistent when it happens.  Sometimes i don't get a value in my base column which is the to date column. and click refresh and it is there and sometimes when I click refresh again.  Different columns will have the same value as each other.  I have 5 ago columns.  It is also not consistent which columns end up the same as each other.  I do not have cacheing turned on in our Development environment.

 

I am not sure if I am using correctly in the analysis.  What I have done is use the Shipped Date is prompted or equal to specific date.  Sometimes the answer comes out just exactly right.  But I cannot count on it not changing.

 

If anyone has any ideas I would really appreciate it.

 

 

 

Base Column

("Core"."RFP Fact - Sales Order Line"."Mill Amount" , "Core"."RFP Shipped Date"."Shipped Year" )

 

Ago Column 1

Ago("Core"."RFP Fact - Sales Order Line"."Shipped YTD Mill Amount"  ,

"Core"."RFP Shipped Date"."Shipped Year",1)

Ago Column 2

Ago("Core"."RFP Fact - Sales Order Line"."Shipped YTD Mill Amount"  ,

"Core"."RFP Shipped Date"."Shipped Year",2)

 

 

Thanks -

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points