1 2 3 Previous Next 35 Replies Latest reply: Dec 31, 2013 1:21 AM by Nikolay Manchev RSS

    Problem with OVM Server 3.2.6 - xend not running

    DBagy

      Hi, just now I upgraded my server to OVM Server 3.2.6 version and server boots up, cluster is up but I have message that Hypervisor is running in UNDETERMINED bit mode (WARNING: XEND IS PROBABLY NOT RUNNING). While boot I saw message that xend failed to start because "mount point /proc/xen does not exist". Also when it tries to start xend, there is message "xencommons should be started first". Reinstalling OVMS did not help. Does anyone have this problem?

      Thanks.

        • 1. Re: Problem with OVM Server 3.2.6 - xend not running
          WadhahDaouehi

          Hi,

          reboot your server and dont select a kernel because by default the boot loader choose the new kernel.

           

          What is the method you choose to upgrade Oracle VM Server (via Oracle VM Manager or vi CD/DVD)?

           

           

          Best Regards

          • 2. Re: Problem with OVM Server 3.2.6 - xend not running
            user11979830

            Hello, I have the same issue, mount point /proc/xen does not exist.

            Have you already resolved it?

            Thanks.

            • 3. Re: Problem with OVM Server 3.2.6 - xend not running
              DBagy

              Hi, it's same whatever I choose while server boot. I've upgraded my server via CD/DVD. In OVM Manager, in server's Events every few seconds I'm getting message:

              TYPE: ServerDiscoverScanEvent

              SEVERITY: Minor

              SUMMARY: Discover Mgr Scan for Server: MY_SERVER, refresh type: All

              • 4. Re: Problem with OVM Server 3.2.6 - xend not running
                DBagy

                Hi,

                I'm still getting the same error.

                • 5. Re: Problem with OVM Server 3.2.6 - xend not running
                  Roddy Rodstein

                  Could you please confirm the following?

                  1- Before updating the hosts you upgraded Oracle VM Manager? Yes / No?

                  2- After the Oracle VM Manager upgrade you upgraded your each Oracle VM Server using a) yum or b) the ISO file? A or B?

                  3- You rebuilt your Oracle VM Servers using the 3.2.6 ISO file and still get the same ServerDiscoverScanEvent error?

                  4- Please post the results from "service xend status" and "service ovs-agent status"

                   

                  Thank you,

                  Roddy

                   

                  • 6. Re: Problem with OVM Server 3.2.6 - xend not running
                    DBagy

                    Roddy, here are the answers to your questions:

                     

                    1 - Yes

                    2 - B

                    3 - Yes

                    4.1 - service xend status:

                    xc: error: Could not obtain handle on privileged command interface (2 = No such file or directory): Internal error

                    Traceback (most recent call last):

                      File "/usr/sbin/xend", line 36, in ?

                        from xen.xend.server import SrvDaemon

                      File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line 26, in ?

                        import relocate

                      File "/usr/lib64/python2.4/site-packages/xen/xend/server/relocate.py", line 28, in ?

                        from xen.xend import XendDomain

                      File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 36, in ?

                        from xen.xend import XendOptions, XendCheckpoint, XendDomainInfo

                      File "/usr/lib64/python2.4/site-packages/xen/xend/XendCheckpoint.py", line 20, in ?

                        from xen.xend import balloon, sxp, image

                      File "/usr/lib64/python2.4/site-packages/xen/xend/image.py", line 46, in ?

                        xc = xen.lowlevel.xc.xc()

                    xen.lowlevel.xc.Error: (1, 'Internal error', 'xc_interface_open failed: No such file or directory')

                     

                    4.2 - service ovs-agent status:

                    log server (pid 4646) is running...

                    notification server (pid 4971) is running...

                    remaster server (pid 4973) is running...

                    monitor server (pid 4975) is running...

                    ha server (pid 4977) is running...

                    stats server (pid 4979) is running...

                    xmlrpc server (pid 4980) is running...

                     

                    Thanks.

                     

                    • 7. Re: Problem with OVM Server 3.2.6 - xend not running
                      user11979830

                      For me, it looks like the same.


                      1 - Yes

                      2 - B

                      3 - Not yet, I've tried to downgrade to 3.2.4, but it is not possible.

                      4.1 - service xend status:


                      xc: error: Could not obtain handle on privileged command interface (2 = No such file or directory): Internal error

                      Traceback (most recent call last):

                        File "/usr/sbin/xend", line 36, in ?

                          from xen.xend.server import SrvDaemon

                        File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line 26, in ?

                          import relocate

                        File "/usr/lib64/python2.4/site-packages/xen/xend/server/relocate.py", line 28, in ?

                          from xen.xend import XendDomain

                        File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 36, in ?

                          from xen.xend import XendOptions, XendCheckpoint, XendDomainInfo

                        File "/usr/lib64/python2.4/site-packages/xen/xend/XendCheckpoint.py", line 20, in ?

                          from xen.xend import balloon, sxp, image

                        File "/usr/lib64/python2.4/site-packages/xen/xend/image.py", line 46, in ?

                          xc = xen.lowlevel.xc.xc()

                      xen.lowlevel.xc.Error: (1, 'Internal error', 'xc_interface_open failed: No such file or directory')

                      xend daemon is stopped


                      4.2 - service ovs-agent status:


                      log server (pid 4460) is running...

                      notification server (pid 4489) is running...

                      remaster server (pid 4492) is running...

                      monitor server (pid 4494) is running...

                      ha server (pid 4496) is running...

                      stats server (pid 4498) is running...

                      xmlrpc server (pid 4499) is running...

                      • 8. Re: Problem with OVM Server 3.2.6 - xend not running
                        Roddy Rodstein

                        Gentlemen,

                         

                        This does indeed look like a 3.2.6 ISO file bug. I have many yum updated 3.2.6 systems that are running without the xend issue.

                         

                        Try this:

                        Lets check the dom0 RPMs via the public latest repo:

                        1) create a repo file on "one" of the Oracle VM Server in the /etc/yum.repos.d/ directory, i.e. /etc/yum.repos.d/public-yum-ovm3.repo with the following contents:

                         

                        [ovm3_latest]
                        name=Oracle VM Server 3 Latest ($basearch)
                        baseurl=http://public-yum.oracle.com/repo/OracleVM/OVM3/latest/x86_64/
                        gpgkey=http://public-yum.oracle.com/RPM-GPG-KEY-oracle-el5
                        gpgcheck=1
                        enabled=1

                         

                        2) yum clean all

                        3) then post the results from: yum check-update

                        • 9. Re: Problem with OVM Server 3.2.6 - xend not running
                          DBagy

                          Roddy,

                          my server isn't allowed to use internet connection, ISO is my only option to upgrade.

                           

                          Thanks.

                          • 10. Re: Problem with OVM Server 3.2.6 - xend not running
                            Roddy Rodstein

                            Can you setup a oracle vm latest yum repo, point your server to the local repo and run yum check-update?

                             

                            This blog post will assist with the yum repo setup: http://itnewscast.com/oracle-linux-yum-server-setup

                            • 11. Re: Problem with OVM Server 3.2.6 - xend not running
                              user11979830

                              Roddy, there are the results:

                               

                              # yum check-update
                              ovm3_latest                                              | 1.2 kB     00:00
                              ovm3_latest/primary                                      | 2.9 MB     00:01
                              ovm3_latest                                                             918/918

                              xen.x86_64                       4.1.3-25.el5.53.26                  ovm3_latest
                              xen-devel.x86_64                 4.1.3-25.el5.53.26                  ovm3_latest
                              xen-tools.x86_64                 4.1.3-25.el5.53.26                  ovm3_latest

                              • 12. Re: Problem with OVM Server 3.2.6 - xend not running
                                Roddy Rodstein

                                Interesting, your machine's xen, xen-devel and the xen-tools rpm packages are not up-to-date. I checked my yum updated 3.2.6 box and it has the above listed rpm packages.

                                 

                                Please patch the box, i.e. yum update -y, and post the output so we can see what packages it had.

                                 

                                Updating the xen-tools rpm should resolves the issue. xend will be updated with the xen-tools rpm.

                                 

                                Its possible that the 3.2.6 ISO upgrade is broke, i.e. not updating the xen, xen-devel and the xen-tools rpm packages...

                                • 13. Re: Problem with OVM Server 3.2.6 - xend not running
                                  user11979830

                                  I updated xend and yum check-update returns empty output now, so it's the latest.

                                  But it doesn't solve the problem with running xend, because mount point /proc/xen still does not exist (and it's the main issue, I think).

                                   

                                  Outputs after reboot:

                                  # service xend status

                                  xc: error: Could not obtain handle on privileged command interface (2 = No such file or directory): Internal error

                                  Traceback (most recent call last):

                                    File "/usr/sbin/xend", line 36, in ?

                                      from xen.xend.server import SrvDaemon

                                    File "/usr/lib64/python2.4/site-packages/xen/xend/server/SrvDaemon.py", line 26, in ?

                                      import relocate

                                    File "/usr/lib64/python2.4/site-packages/xen/xend/server/relocate.py", line 28, in ?

                                      from xen.xend import XendDomain

                                    File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomain.py", line 36, in ?

                                      from xen.xend import XendOptions, XendCheckpoint, XendDomainInfo

                                    File "/usr/lib64/python2.4/site-packages/xen/xend/XendCheckpoint.py", line 20, in ?

                                      from xen.xend import balloon, sxp, image

                                    File "/usr/lib64/python2.4/site-packages/xen/xend/image.py", line 46, in ?

                                      xc = xen.lowlevel.xc.xc()

                                  xen.lowlevel.xc.Error: (1, 'Internal error', 'xc_interface_open failed: No such file or directory')

                                  xend daemon is stopped

                                   

                                  # service ovs-agent status

                                  log server (pid 4383) is running...

                                  notification server (pid 4412) is running...

                                  remaster server (pid 4415) is running...

                                  monitor server (pid 4416) is running...

                                  ha server (pid 4419) is running...

                                  stats server (pid 4421) is running...

                                  xmlrpc server (pid 4422) is running...

                                  • 14. Re: Problem with OVM Server 3.2.6 - xend not running
                                    Roddy Rodstein

                                    Please confirm if the following entry is in /etc/fstab:

                                    xenfs                                     /proc/xen  xenfs   defaults       0 0

                                     

                                    If not the above to /etc/fstab, and type "mount -a"

                                     

                                    What's in /var/log/messages, i.e. xenfs messages?

                                    1 2 3 Previous Next