3 Replies Latest reply: Oct 9, 2013 2:30 AM by JohnGoodwin RSS

    Unable to start Shared Services

    978678

      Hello Everyone,

       

      I have upgraded an existing version of Epm installation on 11.1.2.1 to 11.1.2.3 using the maintenance release method.

       

      I was able to upgrade the environment, most of the applications wors (essbase,workspace,planning,aps,smartview), however i could not get the shared services to work. I could not access shared services through workspace. I have the following error when i try to start the foundation services. the services start but shared services is not working. Can anyone please point me to the right direction on how i should resolve this error

       

       

       

       

      Logs:

      Oct 8, 2013 12:48:35 PM CDT> <Error> <HTTP> <Server> <FoundationServices2> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <0000K6PBjoQ9Tc7InIy0VJ1IL4LQ000002> <1381254515279> <BEA-101216> <Servlet: "WorkflowEngine" failed to preload on startup in Web application: "interop".

      javax.servlet.ServletException: DSF initialization error  ORA-00904: "PROCESSNAME": invalid identifier

       

          at com.hyperion.cesdsf.server.framework.DsfServer.init(DsfServer.java:70)

          at weblogic.servlet.internal.StubSecurityHelper$ServletInitAction.run(StubS

       

      ####<Oct 8, 2013 12:48:35 PM CDT> <Info> <Deployer> <FDM10> <FoundationServices2> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <0000K6PBjoQ9Tc7InIy0VJ1IL4LQ000002> <1381254515295> <BEA-149059> <Module interop of application SHAREDSERVICES [Version=11.1.2.0] is transitioning from STATE_ADMIN to STATE_PREPARED on server FoundationServices2.>

      ####<Oct 8, 2013 12:48:35 PM CDT> <Info> <Deployer> <FDM10> <FoundationServices2> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <0000K6PBjoQ9Tc7InIy0VJ1IL4LQ000002> <1381254515342> <BEA-149060> <Module interop of application SHAREDSERVICES [Version=11.1.2.0] successfully transitioned from STATE_ADMIN to STATE_PREPARED on server FoundationServices2.>

      ####<Oct 8, 2013 12:48:35 PM CDT> <Error> <Deployer> <FDM10> <FoundationServices2> <[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>> <> <0000K6PBjoQ9Tc7InIy0VJ1IL4LQ000002> <1381254515357> <BEA-149231> <Unable to set the activation state to true for the application 'SHAREDSERVICES [Version=11.1.2.0]'.

      weblogic.application.ModuleException: [HTTP:101216]Servlet: "WorkflowEngine" failed to preload on startup in Web application: "interop".

      javax.servlet.ServletException: DSF initialization error  ORA-00904: "PROCESSNAME": invalid identifier

       

          at com.hyperion.cesdsf.server.framework.DsfServer.init(DsfServer.java:70)

          at weblogic.servlet.internal.StubSecurityHelper$ServletInitAction.run(StubSecurityHelper.java:283)

          at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)

          at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)

       

       

      Validation report

      Hyperion Foundation

      FAILED Audit Validating that Audit has been initialized

      Error: http://bas10.mnapps.state.mn.us:19000/interop/status?component=AUDIT

      Recommended Action: Refer to the validation logs for exception details.

      0 seconds

      FAILED CES Validating that CES has been initialized

      Error: http://bas10.mnapps.state.mn.us:19000/interop/status?component=CES

      Recommended Action: Refer to the validation logs for exception details.

      0 seconds

      PASSED CFG: Configuration Validating that configuration tasks have been completed

      0 seconds

      FAILED CSS Validating that CSS has been initialized

      Error: http://bas10.mnapps.state.mn.us:19000/interop/status?component=CSS

      Recommended Action: Refer to the validation logs for exception details.

      0 seconds

      PASSED DB: Database Connectivity Checking connection to database jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=dm01client01-vip.mnapps.state.mn.us)(PORT=1521))(ADDRESS=(PROTOCOL=TCP)(HOST=dm01client02-vip.mnapps.state.mn.us)(PORT=1521))(ADDRESS=(PROTOCOL=TCP)(HOST=dm01client03-vip.mnapps.state.mn.us)(PORT=1521))(ADDRESS=(PROTOCOL=TCP)(HOST=dm01client04-vip.mnapps.state.mn.us)(PORT=1521))(LOAD_BALANCE=yes)(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=BPAS1APX.mnapps.state.mn.us)(FAILOVER_MODE=(TYPE=SELECT)(METHOD=BASIC)(RETRIES=180)(DELAY=5))))

      0 seconds

      PASSED EXT: External Authentication Check Native Directory external authentication provider configuration

      7 seconds

      FAILED HTTP: HTTP Checking availability of HTTP context http://bas10.mnapps.state.mn.us:19000/interop

      Error: Bad response codes with both GET and POST methods: 404 and 404

      Recommended Action: Check that the application is started

      0 seconds

      FAILED HTTP: HTTP Checking availability of HTTP context http://bas10.mnapps.state.mn.us:19000/hyperion-bpma-server/Applications.asmx

      Error: Bad response codes with both GET and POST methods: 503 and 503

      Recommended Action: Check that the application is started

      0 seconds

      FAILED HTTP: HTTP Checking availability of HTTP context http://bas10.mnapps.state.mn.us:19000/WebAnalysis

      Error: Bad response codes with both GET and POST methods: 404 and 404

      Recommended Action: Check that the application is started

        • 1. Re: Unable to start Shared Services
          JohnGoodwin

          Sounds like the upgrade to the Shared Services relational tables has not been applied when the database was configured again.

          If you look in the repository and table CES_PROCESS_DEF do you have a column called PROCESSNAME ? I think in 11.1.2.1 the table had 4 columns and now it should 9

           

          FieldTypeNulls?
          PROCESS_IDVARCHAR2 (100)No
          PARENTVARCHAR2 (100)Yes
          OBJTYPENUMBERNo
          OBJVALUEBLOBYes
          APPLICATIONNAMEVARCHAR2 (100)Yes
          PROCESSNAMEVARCHAR2 (100)Yes
          REVISIONVARCHAR2 (100)Yes
          AUTHORNAMEVARCHAR2 (100)Yes
          DESCRIPTIONVARCHAR2 (100)Yes

           

          Cheers

           

          John

          http://john-goodwin.blogspot.com/

          • 2. Re: Unable to start Shared Services
            978678

            First ...Thank you very much John, asusual you are noting less than spectacular. you are right i checked the table and it had only four columns, looks like the db has not been configured.

             

            Now when i try to configure the database using the epm configurator, i am unable to select the check box next, am i  missing some special option here.

             

            I was pretty much able to do everything else except configure database on foundation services, can you please point me to the right direction here

            • 3. Re: Unable to start Shared Services
              JohnGoodwin

              To be able to configure the Share Services database you can go to command line

              cd to <MIDDLEWARE_HOME>/EPMSystem11R1/common/config/11.1.2.0 and run configtool.bat -enableRegTask  or .sh if on unix type systems

              I am not saying that will fix the issue but make sure you have backups before running anything so you can roll back.

               

              Cheers

               

              John

              http://john-goodwin.blogspot.com/