8 Replies Latest reply: Oct 9, 2013 7:34 AM by Srini Chavali-Oracle RSS

    Unable to start EBS DB after the Server Crash. Error in installing the Required RPM.

    MZ_AppsDBA

      Hi , Hussein ( As most of the Time It is Only you here who comes to the rescue or give Usefull inputs. I am sorry if i mistaken, no Pan intended for Other Experts)


      I 've also posted this issue here but got no response. https://forums.oracle.com/thread/2590497 

       

      Badly require your inputs and suggestions on the Following Issue. , Really Appreciate the suggestions.


      I need to Install the sabayon-apply rpm which could fix the issue after the Server Crash but unable to install it.

         Please see the Brief of the Issue.

       

      I got stuck up in installing the rpm after the server(Red Hat Enterprise Linux Server release 6.0 (Santiago) x86_64 GNU/Linux) got
      crashed Eventhough I am able to start it in Xwindows but not able to run or start EBS database along with many other programmes. Also The
      VirtualBox machine installed on it 've No issue, they work fine  But the host OS is not fine. as there are lots of
      errors in .xsession-errors. which i 've pasted below.  And Unable to Install the sabayon-apply rpm that could have fix the Issue.


      I would highly Appreciate if anyone could drop few hints and suggestions on this Issue as this is really Urgently Important for me.


      Please see the following Brief of the Issue.


        after starting the server in Xwindows I was installing the rpms from RHEL6/Packages directory on the server even installed 10-12 rpms

        While installing the rpm i 've inadvertantly issued or run  this command

        rpm -ivh *.rpm --force --nodeps  as it ended up with Errors Header V3 RSA/SHA256 Signature, key ID fd431d51: BAD


          After That I could Not Install any rpm with yum or rpm command as getting the Same Errors. 


      while trying to install individual rpm am getting the followig Errors
      [root@ebs Packages]# rpm -ivh libX11*
      error: libX11-1.3-2.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID fd431d51: BAD
      error: libX11-1.3-2.el6.i686.rpm cannot be installed

      [root@ebs Packages]# rpm --checksig gtk2*
      gtk2-2.18.9-4.el6.i686.rpm: RSA SHA1 (MD5) PGP MD5 NOT OK
      gtk2-2.18.9-4.el6.x86_64.rpm: RSA SHA1 (MD5) PGP MD5 NOT OK
      gtk2-devel-2.18.9-4.el6.i686.rpm: RSA SHA1 (MD5) PGP MD5 NOT OK
      gtk2-devel-2.18.9-4.el6.x86_64.rpm: RSA SHA1 (MD5) PGP MD5 NOT OK
      gtk2-devel-docs-2.18.9-4.el6.x86_64.rpm: RSA SHA1 (MD5) PGP MD5 NOT OK
      gtk2-engines-2.18.4-5.el6.i686.rpm: RSA SHA1 (MD5) PGP MD5 NOT OK
      gtk2-engines-2.18.4-5.el6.x86_64.rpm: RSA SHA1 (MD5) PGP MD5 NOT OK
      gtk2-immodule-xim-2.18.9-4.el6.x86_64.rpm: RSA SHA1 (MD5) PGP MD5 NOT OK

      For that I tried to import the RPM GPG Key But still faced the same errors

      [root@ebs yum.repos.d]# wget
      http://public-yum.oracle.com/RPM-GPG-KEY-oracle-ol6 -O /etc/pki/rpm-gpg/RPM-GPG-KEY-oracle Key fingerprint = 4214 4123 FECF
      C55B 9086  313D 72F9 7B74 EC55 1F03


      --2013-10-08 00:04:56-- 
      http://public-yum.oracle.com/RPM-GPG-KEY-oracle-ol6
      Resolving public-yum.oracle.com... 202.159.216.177, 202.159.216.171
      Connecting to
      public-yum.oracle.com|202.159.216.177|:80... connected.
      HTTP request sent, awaiting response... 200 OK
      Length: 1011 [text/plain]
      Saving to: “/etc/pki/rpm-gpg/RPM-GPG-KEY-oracle”

      FINISHED --2013-10-08 00:05:06--
      Downloaded: 6 files, 55K in 2.0s (27.7 KB/s)
      100%[===========================================================================================================================================================>]
      1,011 --.-K/s   in 0s

      2013-10-08 00:04:56 (155 MB/s) - “/etc/pki/rpm-gpg/RPM-GPG-KEY-oracle”
      saved [1011/1011]

         Than i run this command
      [root@ebs yum.repos.d]# rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-oracle  ----it Returns with no output
      [root@ebs yum.repos.d]#

      [root@ebs log]# rpm -q gpg-pubkey-ec551f03-4c2d256a
      gpg-pubkey-ec551f03-4c2d256a

      But still I can't install the rpms, got the same Errors. please see the following

      [root@ebs yum.repos.d]# yum install firefox*
      Loaded plugins: refresh-packagekit, rhnplugin
      This system is not registered with RHN.
      RHN support will be disabled.
      Setting up Install Process
      ----------------------------
      ------------------------------
      --------------------------

      Downloading Packages:
      (1/2): firefox-17.0.9-1.0.1.el6_4.x86_64.rpm

        |  25 MB     03:42
      (2/2): xulrunner-17.0.9-1.0.1.el6_4.x86_64.rpm

        |  14 MB     02:03
      -----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
      Total

      117 kB/s |  39 MB     05:46
      error: rpmts_HdrFromFdno: Header V3 RSA/SHA256 Signature, key ID ec551f03: BAD


      Problem opening package xulrunner-17.0.9-1.0.1.el6_4.x86_64.rpm


      [root@ebs log]# rpm -qf `which gpg`
      error: rpmdbNextIterator: skipping h#     455 Header V3 RSA/SHA256
      Signature, key ID fd431d51: BAD

      [root@ebs log]# gpg --list-keys
      /root/.gnupg/pubring.gpg
      ------------------------
      pub 1024D/11F63C51 2002-02-28
      uid Jamie Cameron <
      jcameron@webmin.com>
      sub 1024g/1B24BE83 2002-02-28

      pub 2048D/671DF296 2013-10-08
      uid oracle
      sub 2048g/9FE459CE 2013-10-08

      pub 1024R/F3A5AC78 2013-10-08
      uid oracle (no comment) <
      oracle@oracle.com>
      sub 1024R/6DC65985 2013-10-08

      pub 1024R/78F6C944 2013-10-08
      uid root user (Example GPG Key Signature For RPM
      Packages) <
      root@root.com>
      sub 1024R/77C97AFF 2013-10-08


      [root@ebs log]# rpm -qi 'gpg-pubkey-*'
      Name : gpg-pubkey Relocations: (not relocatable)
      Version : ec551f03 Vendor: (none)
      Release : 4c2d256a Build Date: Wed 09 Oct
      2013 01:09:10 AM IST
      Install Date: Wed 09 Oct 2013 01:09:10 AM IST      Build Host: localhost
      Group : Public Keys Source RPM: (none)
      Size : 0 License: pubkey
      Signature : (none)
      Summary : gpg(Oracle OSS group (Open Source Software group)
      <
      build@oss.oracle.com>)
      Description :
      -----BEGIN PGP PUBLIC KEY BLOCK-----
      Version: rpm-4.8.0 (NSS-3)

      mQENBEwtJWoBCACpiY2rGA6T0ceBi92X88/QclytVBjtDRohOVzs3pmIPh3ULqsW
      G323nmyKbKQBBSjh9OnuO9Y09VG8mzr/w9YV0Ix4cI9/HDTERZ2+TR5u+VNn5J5h
      yvwQSN/FEK6oH2+mz7O0yUNleN7UltR4MOEkHIoAhIvv+1AQQKN3OM8oalz+3gv/
      zz9rAoQczQzT7QWOtBrsRMZgBrKXY/TpJrpVSO3Hx8CnbhKGtLxCCrxZ5v7hh1ht
      3CRAr2+h5bDA9KP6vBZWKEs7NgcvtZFDY6EJc7AoApr3phX9hHE2+snTxe82DkFT
      uA69C8wLyjPCoSy+tcaCqJKOZelNy9RN/WKRABEBAAG0RE9yYWNsZSBPU1MgZ3Jv
      dXAgKE9wZW4gU291cmNlIFNvZnR3YXJlIGdyb3VwKSA8YnVpbGRAb3NzLm9yYWNs
      ZS5jb20+iQE8BBMBAgAmBQJMLSVqAhsDBQkWjmoABgsJCAcDAgQVAggDBBYCAwEC
      HgECF4AACgkQcvl7dOxVHwMiNAf/cD8R74fCBeQsAYid5slIz7CG8xEOBUTDNEJT
      p/owtzr7m7Ydp1txNBOkVeVkUP8czX5EldcmoxA4kCCyHhnxmpJnOt52Fy5ZRnYh
      Ll5gYdpJpXGVScB7fnlh3rJAaesSTacVFC5MKIYPZBiTo9soSXMLNcG8WqHPasdd
      AblC4t5BTDNYlX1RiPeP6m5egHnnxyAXsis8fqIZY0RC9hERxWQ6hdDAX0tJXY8F
      88HDUozvo8jqTlg/5GZcfqcbUjjMUJQ5cBtH3adCthMycdPpPXWJQBuzMIdFJ03u
      YuQ3XrKxBkOLips+OZuWNVZzrPOHsenb49aX4yQsLVc2E2fhKQ==
      =M8XY
      -----END PGP PUBLIC KEY BLOCK-----



      I 've tried to remove the existing keys But Not able to remove them as well.

      Is this the right way of removing the keys ?
      rpm -e --allmatches 'gpg-pubkey-ec551f03-*'  the ec551f03 is the
      version of rpm -qi 'gpg-pubkey-*' query...  Please correct
       
      Could you tell what I am missing here that's causing the Issue.
       
      Following are the Errors that is observed in .xsession-errors log file



      ===== BEGIN RING BUFFER (/usr/sbin/sabayon-apply) =====
      MainThread 2013/10/08 18:34:23.3001 (sabayon-apply): No profile for
      user 'root' found
      MainThread 2013/10/08 18:34:23.3005 (sabayon-apply): Fatal exception!
      Exiting abnormally.
      MainThread 2013/10/08 18:34:23.3009 (sabayon-apply): Traceback (most
      recent call last):
      File "/usr/sbin/sabayon-apply", line 149, in <module>
      sys.exit (util.EXIT_CODE_NO_USER_PROFILE)
      SystemExit: 3

      ===== END RING BUFFER (/usr/sbin/sabayon-apply) =====


      This configuration for the debug log can be re-created
      by putting the following in ~//etc/sabayon/sabayon-debug-log.conf
      (use ';' to separate domain names):

      [debug log]
      max lines = 1000
      gnome-session[3707]: EggSMClient-WARNING: Desktop file
      '/etc/xdg/autostart/esc.desktop' has malformed Icon key
      'esc.png'(should not include extension)
      GNOME_KEYRING_SOCKET=/tmp/keyring-x5SKbN/socket
      SSH_AUTH_SOCK=/tmp/keyring-x5SKbN/socket.ssh
      Failed to play sound: Not available

      (polkit-gnome-authentication-agent-1:3917): GLib-GObject-WARNING **:
      cannot register existing type `_PolkitError'

      (polkit-gnome-authentication-agent-1:3917): GLib-CRITICAL **:
      g_once_init_leave: assertion `initialization_value != 0' failed
      W: main.c: This program is not intended to be run as root (unless
      --system is specified).
      ** Message: applet now removed from the notification area


      ** (gnome-user-share:3948): WARNING **: gnome-user-share cannot be
      started as root for security reasons.
      08/10/2013 06:34:26 PM Autoprobing TCP port in (all) network interface
      08/10/2013 06:34:26 PM Listening IPv{4,6}://*:5900
      08/10/2013 06:34:26 PM Autoprobing selected port 5900
      08/10/2013 06:34:26 PM Advertising authentication type: 'No Authentication' (1)
      08/10/2013 06:34:26 PM Advertising security type: 'No Authentication' (1)
      Initializing nautilus-gdu extension
      Initializing nautilus-open-terminal extension
      ** Message: applet now embedded in the notification area
      Connecting to deprecated signal
      QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
      kbuildsycoca4 running...
      Connecting to deprecated signal
      QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
      Connecting to deprecated signal
      QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
      Window manager warning: Invalid WM_TRANSIENT_FOR window 0x4e00004
      specified for 0x4e00019 (Restore Se).
      Object::disconnect: Unexpected null parameter
      QObject::connect: Cannot connect (null)::activePartChanged(
      KParts::Part * ) to KHTMLPart::slotActiveFrameChanged( KParts::Part *
      )
      kio_http_cache_cleaner: Already running!
      Object::disconnect: Unexpected null parameter



      Window manager warning: Invalid WM_TRANSIENT_FOR window 0x5200004
      specified for 0x5200019 (Restore Se).
      Object::disconnect: Unexpected null parameter
      QObject::connect: Cannot connect (null)::activePartChanged(
      KParts::Part * ) to KHTMLPart::slotActiveFrameChanged( KParts::Part *
      )
      Object::disconnect: Unexpected null parameter
      QObject::connect: Cannot connect (null)::activePartChanged(
      KParts::Part * ) to KHTMLPart::slotActiveFrameChanged( KParts::Part *
      )
      Object::disconnect: Unexpected null parameter
      Window manager warning: Invalid WM_TRANSIENT_FOR window 0x4e00004
      specified for 0x4e08cb7 (timesofind).
      libpng warning: Extra compressed data in IDAT
      Window manager warning: Invalid WM_TRANSIENT_FOR window 0x4e00004
      specified for 0x4e0a6e3 (Server Aut).


      Highly appreciate the response.



      Thanks And Regards
      MZ