1 Reply Latest reply: Oct 23, 2013 2:04 AM by Hibai_ RSS

    Enabling CDC on runtime only

    903706

      Hi all,

       

      I have a separate site For production that has a separate master repository and runtime only work repository.

       

      I added a simple CDC interface to my system, but as simple as it seems to do that on dev, I find it hard to do the same witout the designer on my runtime environment.

       

      What am I missing?

       

      Nimrod

        • 1. Re: Enabling CDC on runtime only
          Hibai_

          Hi Nimrod,

           

          Are you performing CDC-related steps (Start journal, Add to CDC, etc.) manually? - manually means right click on the model, and then Change Data Capture > Add to CDC, etc. If so, you should include those steps in your package, so that they will be executed when you export the scenario to Prod environment.

           

          The steps should be defined as follows:

           

          1. Add to CDC + Start Journal: drag and drop the model you have to monitor to the package. Then select "Journalizing Model" from the Type list. Afterwards check "Start" and "Add Subscribers" options, and add the subscriber you will use (just enter the name and click on "Add" button).

           

          2. Extend Window + Lock Subscribers: drag and drop the model again, and now you have to check "Extend Window" and "Lock Subscribers" options. Select the previously defined subscriber.

           

          3. Purge Journal + Unlock Subscribers: after you have integrated your data via interfaces (I assume you already have this step), check "Purge Journal" and "Unlock Subscribers" in the model step. Select again the subscriber.

           

          You will probably have to define as a very first step an OdiWaitForLogData step, which will be waiting for new changes in your model, and which will allow you to complete the full CDC-cycle.

           

          Take a look also to the following article: http://odiexperts.com/cdc-consistent/

           

          Hope this will help. Regards,

           

          Hibai.