6 Replies Latest reply: Oct 29, 2013 9:08 PM by Rahul-Em-Oracle RSS

    The OEM not start. User sysman is locked

    Jurandyr

      Dear,

       

             I can't start my OEM why password the user sysman expired. I changed password of user sysman and unlock, but always start OEM the user sysman lock again. I use Oracle Database 11gr2.

       

             I´ve already the steps below, but it not solved my problem.

       

      To change the Sysman password:

      1. Stop the OMS instances that are associated with the repository

      a. opmnctl stopall

       

      2. Change the sysman password in the database:

      a. Logon to sqlplus as a dba user

      b. Issue the command: alter user sysman identified by newpassword;

      c. Exit Sqlplus

       

      3. On each management server host, cd to the OMS $ORACLE_HOME/sysman/config directory

      a. backup the emoms.properties file

      b. edit the emoms.properties file and modify the parameters;

      eml.mntr.emdRepPwd=new_password

      oracle.sysman.eml.mntr.emdRepPwdEncrypted=FALSE

       

      NOTE: When you restart the OMS, the FALSE setting will change to TRUE and the password will become encrypted in the file

       

      4. Still on Management Repository host, cd to the AGENT_HOME/bin and stop the agent:

      ./emctl stop agent

      5. Next, cd to the AGENT_HOME/sysman/emd directory

      a. Edit the targets.xml file and modify the oracle_emrep target definition with the following in bold:

      <Target TYPE="oracle_emrep" NAME="Management Services and Repository" VERSION="1.0">

      <Property NAME="MachineName" VALUE="host.us.oracle.com"/>

      <Property NAME="Port" VALUE="1521"/>

      <Property NAME="SID" VALUE="sid"/>

      <Property NAME="UserName" VALUE="552f2080d6d8c3c6" ENCRYPTED="TRUE"/>

      <Property NAME="password" "newpassword" ENCRYPTED"FALSE"/>

      ..

      ..

      b. Save the file. The TRUE value will change to FALSE and the newpassword will become encrypted when you restart the Agent.

       

      6. Issue the command (from the Agent O_H/bin):

      ./emctl start agent

       

      7. Restart each of the OMS's

      emctl start oms

       

       

      How can I do to solve this problem?

      I can't also drop repository of the OEM.

       

      Thanks

       

      Jurandyr F. Alves