0 Replies Latest reply on Oct 23, 2013 5:55 PM by fru92thu

    rollback GI & DB patch then watch-out


      Today I  tried to patched my RAC One Node (2 node) cluster to I was on prior to this.


      I started by only patching Grid Infrastructure & DB home on node 2.  The GI patch was successful but the DB patch had 1 failure so I decided to rollback the DB patch - this also rolled back my GI patch.


      Everything was back to and when I tried to restart my acfs resource on node 2 it failed to start with an ACFS/ADVM kernel not supported error. The acfs resource was working on node 1 which has exactly the same kernel version!!!!


      After loads of searching I found out that although Oracle had rolled back the patch, it didn't update or use the correct osds_acfslib.pm (located in $GRID_HOME/lib). This file that Oracle either replaced with a vanilla copy of modified didn't have a section in it for

      my kernel version - 2.6.32-400


      I therefore copied the fresh copy of this file from node 1 to node 2 and then ran


      acfsload start -s


      lsmod | grep oracle


      --- this then showed






      crsctl start res <acfs resource name> -n <node name>


      ACFS started fine after this! Hope it helps someone...