4 Replies Latest reply on Nov 1, 2013 10:01 AM by 1023935

    Required RPM's for suse linux 11 for 11.2.0.3 installation

    1023935

      Hi all,

      O.S  - SUSE Linux Enterprise Server 11 (x86_64)

      Db - 11.2.0.3

       

      I am installing 11.2.0.3 on suse linux for prerequisite i am getting error for required packages can anybody tell me from where to download these packages.

      I dont have the DVD so i cant mount and install the rpm's .From zypper i am getting this error

       

      expdev1:~ # zypper install libstdc++-3.4.6

      Loading repository data...

      Reading installed packages...

      'libstdc++-3.4.6' not found.

      Resolving package dependencies...

       

       

      Nothing to do.

       

      Can anybody help me in this

        • 1. Re: Required RPM's for suse linux 11 for 11.2.0.3 installation
          Mahir M. Quluzade

          Hi,

           

           

          Yes you can install Oracle Database 11.2 to Suse Linux :

           

          On SUSE Linux Enterprise Server 10

          2.6.16.21 or later

          On SUSE Linux Enterprise Server 11

          2.6.27.19 or later

           

          Package Requirements

           

          The following or later version of packages for SUSE Linux Enterprise Server 10

          must be installed:

          binutils-2.16.91.0.5

          compat-libstdc++-5.0.7

          gcc-4.1.0

          gcc-c++-4.1.2

          glibc-2.4-31.63

          glibc-devel-2.4-31.63

          glibc-devel-32bit-2.4-31.63

          ksh-93r-12.9

          libaio-0.3.104

          libaio-32bit-0.3.104

          libaio-devel-0.3.104

          libaio-devel-32bit-0.3.104

          libelf-0.8.5

          libgcc-4.1.2

          libstdc++-4.1.2

          libstdc++-devel-4.1.2

          make-3.80

          numactl-0.9.6.x86_64

          sysstat-8.0.4

          ■ The following or later version of packages for SUSE Linux Enterprise Server 11

          must be installed:

          binutils-2.19

          gcc-4.3

          gcc-32bit-4.3

          gcc-c++-4.3

          glibc-2.9

          glibc-32bit-2.9

          glibc-devel-2.9

          glibc-devel-32bit-2.9

          ksh-93t

          libaio-0.3.104

          libaio-32bit-0.3.104

          libaio-devel-0.3.104

          libaio-devel-32bit-0.3.104

          libstdc++33-3.3.3

          libstdc++33-32bit-3.3.3

          libstdc++43-4.3.3_20081022

          libstdc++43-32bit-4.3.3_20081022

          libstdc++43-devel-4.3.3_20081022

          libstdc++43-devel-32bit-4.3.3_20081022

          libgcc43-4.3.3_20081022

          libstdc++-devel-4.3

          make-3.81

          sysstat-8.1.5

           

          Why you not checked : http://docs.oracle.com/cd/E11882_01/install.112/e24326.pdf

           

          and Please check : https://www.suse.com/LinuxPackages/packageRouter.jsp?product=server&version=11&service_pack=&architecture=ppc&package_na…

          https://www.suse.com/LinuxPackages/packageRouter.jsp?product=server&version=11&service_pack=&architecture=i386&package_name=libstdc%2B%2B33

           

          Regards

          Mahir M. Quluzade

          • 2. Re: Required RPM's for suse linux 11 for 11.2.0.3 installation
            1023935

            Thanks Mahir,

            yes i have checked that but the problem is i dont have those packages, so i continued with those already installed by default.We dont have the OS admin here and this is the image of the OS on vmware.

            I dont have those packages from current zypper repositories.

             

            from where can i get these packages(online or any download location)

             

            Also what will happen if i ignore them and continue installation?

            Missing packages (only seven)

            compat-libstdc++-33-3.2.3(x86-64)

            elfutils-libelf-0.97(x86-64)

            elfutils-libelf-devel-0.97

            glib-common-2.3.4

            glib-headers-2.3.4

            libgcc-3.4.6(x86-64)

            libstdc++-3.4.6(x86-64)

             

            Thanks.

            • 3. Re: Required RPM's for suse linux 11 for 11.2.0.3 installation
              Mahir M. Quluzade

              ed22e531-43ba-4278-b0e4-8b4359782c83 wrote:

               

              Thanks Mahir,

              yes i have checked that but the problem is i dont have those packages, so i continued with those already installed by default.We dont have the OS admin here and this is the image of the OS on vmware.

              I dont have those packages from current zypper repositories.

               

              from where can i get these packages(online or any download location)

               

              Also what will happen if i ignore them and continue installation?

              Missing packages (only seven)

              compat-libstdc++-33-3.2.3(x86-64)

              elfutils-libelf-0.97(x86-64)

              elfutils-libelf-devel-0.97

              glib-common-2.3.4

              glib-headers-2.3.4

              libgcc-3.4.6(x86-64)

              libstdc++-3.4.6(x86-64)

               

              Thanks.

               

              No, you must install all required packages before installation.

              You  can  download from Suse's web site, which is I replied before (login require).

              Really I  haven't any idea, why this packages not in zypper repositories.

               

              Try again, use full name of package from zypper repositories.

               

              Regards

              Mahir M. Quluzade

              • 4. Re: Required RPM's for suse linux 11 for 11.2.0.3 installation
                1023935

                I have once again gone through that document for required packages and the list of package warnings i have got.

                I checked each package by "rpm -q" as mentioned and i found that  all the required packages are already installed,but while installing oracle it is giving warning for new list of packages which i think is not required at all and also they are not mentioned in the document as well further i think this is behaviour while installing on vmware.The solution is to ignore it and continue which i did, the installation is completed  successfully with no errors.

                Somewhere i found that we need to change the config file before installation to avoid these warnings.