1 Reply Latest reply on Dec 4, 2013 11:55 AM by user3013978

    URL mapping in Apex Listener 2.0.5

    Doevelaar

      Hi all,
      I'm trying to configure a standalone Apex listener in such a way so that I can use 2 URL's:

      http://localhost:8888/apex/e1/f?p=103 => points to version 1 of my application

      http://localhost:8888/apex/e2/f?p=106 => points to version 2 of my application

       

       

      I'm configuring the Apex Listener via SQL Developer. I added 2 connections next to the existing 'apex' connection in the listener config: apex_e1 and apex_e2.

       

       

      Then I added URL-mapping to the apex_e1 and apex_e2 connections. I used Request path mapping, with routing rule

      /e1 and /e2. So the URLs for the applications look like:

       

      http://localhost:8888/apex/e1/f?p=103

      and

      http://localhost:8888/apex/e2/f?p=106

       

      In the pre-processing property of both connections, I want to run code to point the session to the correct edition (I'm using Edition Based Redefinition). I added pre-processing procedures to both database-connections in the listener, but they don't seem to run. I added logging in the procedures, and no logging is written. If I add the same call to the pre-processing of the GLOBAL config, it is executed.

       

      Am I making some mistake in the URL mapping that results in no preprocessing being done?

      Using Apex 4.2.2, SQL Developer 3.2.20.10 and Apex Listener 2.0.5 standalone.

        • 1. Re: URL mapping in Apex Listener 2.0.5
          user3013978

          Hi Doevelaar,

           

          sorry, no help but: Iam fighting like you.

           

          I tried the same to get multiple databases to live: no result

          I tried to get a connection to configure apex-listener running under Glassfish via SQL-Developer: no Connection possible

          I tried to get a connection to configue apex-listener via SQL-Developer : this works if Apex-Listener runs standalone but: I can't store the configuration

           

          I am surely a Oracle-fan with APEX and the DBMS but all installations of Oracle makes me mad.

          Try to install the dbms 3 times, it will react 3 times different.

          The clone tool of db's works one day, the next one it stops anywhere without any online comment (anywhere in hidden logs you will find a miracle error description.. java-errors self explaining if you know all libaries)

           

          I dont know who ever makes quality checks there but they need any old guy, not the young hackers.

          I think Bill Gates has time.

           

          I am so frustrated with all this installation stuff and sh..., i hope one day microsoft buys Oracle, then the installation may be smooth and all features will work.

          And you dont have to be a script guru to manage an update, may be. This is naturally only a daydream...

           

          I work like you at this problem, if I have  any solution I let you know.

          Cheers

          me