6 Replies Latest reply: Nov 8, 2013 8:26 AM by jrimblas RSS

    Enkitec Sparkline in IR Report

    Sky13

      I am working with the Enkitec Sparkline plugin.  I have had some very nice results with it as a page item.  Now I am trying to use it in an IR report.  I have the values in a column named VALUE_HIST.  The value is a comma separated string of numbers.  The problem I am having is how to get the plugin to fire on the column.  I have placed #VALUE_HIST in the jquery field but no luck.

       

      Any help would be great.

        • 1. Re: Enkitec Sparkline in IR Report
          scott.wesley

          You'll probably get the fastest response if you recreated on apex.oracle.com

           

          Have you surrounded the value in the report with a div? (using HTML expression)

          • 2. Re: Enkitec Sparkline in IR Report
            jrimblas

            Without knowing how you set things up it's hard to say.  What is the markup you're using?

            If you're using a span tag, it's probably being escaped.  Use the "HTML Expression" field.  For example

            <span class="value_hist">#VALUE_HIST#</spa>

             

            Then use .value_hist as the selector.  Because this is in a report, you have many entries.  So instead of an ID  (#VALUE_HIST) as a selector use a class (.VALUE_HIST).

             

            You probably have seen this sample page right?

            http://www.enkitec.com/apex/f?p=15200:20

             

            Hope this helps

            Thanks

            -Jorge

            • 3. Re: Enkitec Sparkline in IR Report
              Sky13

              Thanks for the replies.  Yes I did see the sample on the Enkitec page but I did not see catch how to make the Plugin "fire" (for lack of a better term). It worked when I put the .value_hist as jquery selector.  Thanks!

              • 4. Re: Enkitec Sparkline in IR Report
                jrimblas

                Great!

                One more thing, to make the plugin fire again after the IR refreshes I would simply change the DA to trigger on After Refresh instead of on Page Load.

                AND make sure that the plugin also has the Fire on page load option checked.  This way you get two thing: It runs when the page loads and every time the IR changes.

                 

                Hope this helps.

                Thanks

                -Jorge

                • 5. Re: Enkitec Sparkline in IR Report
                  Sky13

                  Hi Jorge,

                  Thanks again for the help.  You know what is interesting is I have two pages each as an IR report. The first page only has one column that uses a Sparkline the other has three.  I have the DA on both setup to fire After Refresh on the IR rejoin and the plugins (all 4 instances) to fire on page load.  Only the DA one the page with one Sparkline column works when the IR is refreshed.  The report with the thee Sparkline Columns shows the Sparkline when the page is loaded but when the IR is changed it shows the value string.  I am not sure if I have this messed up our if something else is going on.

                   

                  Also I have one more question.  Let me know if I should do a separate post for this;

                  I want to show the X axis value along with the Y axis value in the tool tip of my Sparklines. Something like this "125 on 6/13/2013".  Can this be done?

                  • 6. Re: Enkitec Sparkline in IR Report
                    jrimblas

                    Sky13 wrote:

                     

                    Hi Jorge,

                    Thanks again for the help.  You know what is interesting is I have two pages each as an IR report. The first page only has one column that uses a Sparkline the other has three.  I have the DA on both setup to fire After Refresh on the IR rejoin and the plugins (all 4 instances) to fire on page load.  Only the DA one the page with one Sparkline column works when the IR is refreshed.  The report with the thee Sparkline Columns shows the Sparkline when the page is loaded but when the IR is changed it shows the value string.  I am not sure if I have this messed up our if something else is going on.

                     

                    Also I have one more question.  Let me know if I should do a separate post for this;

                    I want to show the X axis value along with the Y axis value in the tool tip of my Sparklines. Something like this "125 on 6/13/2013".  Can this be done?

                    Odd, I'm not sure why, it would need a little troubleshooting.  Perhaps there's a JS error somewhere/  Try looking in the console.

                    If that doesn't get you there, try to replicate it in apex.oracle.com and provide developer credentials to take a look.

                     

                    For the extra question, I'm going to say yes I think it's possible, but I'm no Sparkline expert so it would be best to start a new question and let someone who knows chime in.

                     

                    Thanks

                    -Jorge