This discussion is archived
1 Reply Latest reply: Nov 10, 2013 3:59 PM by Dude! RSS

Missing dependency error while installing  kernel-2.6.32-358.el6.x86_64 and yum-utils package

user560527 Newbie
Currently Being Moderated

Hi Experts,

 

I'm not able to install the kernel in Oracle Linux using "Yum install". I'm getting error's while installing Kernel. The Kernel version is 2.6.32-358.el6.x86_64 (in the linux CD of virtual box) Can you please guide me how to proceed further.

I used the commands below :

wget http://public-yum.oracle.com/public-yum-ol6.repo

yum install kernel-2.6.32-358.el6.x86_64

I'm getting so many errors saying "Error Missing Dependency libpq.so.4() 64bit" Error missing dependency libmysqlclient.so.15()64 bit

Please find screenshot below : http://imageshack.com/a/img30/33/kp5z.jpg

I searched through the net and tried using "yum clean all" and yum update etc.. but the problem is not resolved...

Please note I booted from a linux Oracle linux 6 bootable CD and trying to install Oracle Linux 6 kernel on my machine..

I tried installing "yum-utils" package too using the below command, but that too failed giving missing dependency errors..

Yum install yum-utils

 

I dont' know much about linux and stuck with the issues above for more than 30 days now... please help...

 

Regards Jags

  • 1. Re: Missing dependency error while installing  kernel-2.6.32-358.el6.x86_64 and yum-utils package
    Dude! Guru
    Currently Being Moderated

    You cannot use the yum utility to do a major version upgrade, such as upgrading from Oracle Linux 5 to Oracle Linux 6. Kernel version 2.6.32-358.el6 is the RHCK kernel and requires Oracle Linux 6. So if your attempt was to install a driver that works only for the Red Hat Enterprise Linux 6 kernel, you will have to upgrade the OS first. For this you must start from the OL6 installation DVD, but upgrading between major release versions is not officially supported. You can however upgrade to the latest Oracle UEK kernel, by enabling the appropriate channel in the yum repository configuration file.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points