2 Replies Latest reply on Nov 17, 2013 2:31 PM by Paul M.

    connection using DEVSUITE

    941949

      dear all,

                    how are you,everybody?i need your valuable help,i installed 11g database on win7 64 bit OS and i also installed 10g forms and reports builder.When I m trying to connect to database 11g from 10g DEVSUITE HOME  through TOAD .i m getting error as ERROR:12154 tns name could not resolved the connect identifier specified (ORCL).

                           I added details of ORCL  into the TNS of DEVSUITE HOME  after that also i m getting the same error as mentioned above when i tried to connect to ORCL throuch TOAD using DEVSUITE HOME.

       

      OS:win7 64 bits

      DEVSUITE 10g

       

      thanks.

        • 1. Re: connection using DEVSUITE
          Paul M.
          I added details of ORCL  into the TNS of DEVSUITE HOME

          Are you sure you added it in the correct tnsnames.ora ? and there aren't syntax errors ?

          $ oerr ora 12154

          12154, 00000, "TNS:could not resolve the connect identifier specified"

          // *Cause:  A connection to a database or other service was requested using

          // a connect identifier, and the connect identifier specified could not

          // be resolved into a connect descriptor using one of the naming methods

          // configured. For example, if the type of connect identifier used was a

          // net service name then the net service name could not be found in a

          // naming method repository, or the repository could not be

          // located or reached.

          // *Action:

          //   - If you are using local naming (TNSNAMES.ORA file):

          //      - Make sure that "TNSNAMES" is listed as one of the values of the

          //        NAMES.DIRECTORY_PATH parameter in the Oracle Net profile

          //        (SQLNET.ORA)

          //      - Verify that a TNSNAMES.ORA file exists and is in the proper

          //        directory and is accessible.

          //      - Check that the net service name used as the connect identifier

          //        exists in the TNSNAMES.ORA file.

          //      - Make sure there are no syntax errors anywhere in the TNSNAMES.ORA

          //        file.  Look for unmatched parentheses or stray characters. Errors

          //        in a TNSNAMES.ORA file may make it unusable.

           

          Did you try Using the Easy Connect Naming Method ?  See 8 Configuring Naming Methods

          • 2. Re: connection using DEVSUITE
            Paul M.

            Also be aware that Developer Suite 10g is not certified on win7 64 bit.

             

            See MOS Doc ID 1292919.1 Certification of Oracle Developer Suite 10g (10.1.2) on Windows 7 (32-bit)