2 Replies Latest reply on Nov 18, 2013 4:54 PM by rp0428

    Huge defect with SQL Developer and OSX Mavericks

    ebb730b5-e781-4d85-9f2c-edac9fef8a59

      I installed SQL Developer previously, when I had an earlier version of OSX.  Later on, i decided to update, and once I did, it seemed that SQL Developer no longer worked.  The icon would just hop up and down on the dock.  I eventually found that it was unable to locate my java installation...so I ran SQL Developer via the command line and it asked me for the Java installation, which I provided.  Great...problem solved right?  Wrong.  It turns out that when that icon was bouncing up and down, and SQL Developer was trying to start...it filling up my disk with log files.  I only came to notice this because I recieved notifications that my startup disk was nearing capacity.  Using some hand du commands, I found that /private/tmp had over 120 GB worth of data in it....then upon examining that i found that the entirety of that was in two SQL Developer log files...both roughly 60GB.  Those files were filled with the command that I saw on the command line when running SQL Developer...Unable to locate your J2SE installation (or something like that...unfortunately I deleted them before thinking this post through).  This seems like a pretty bad one to me, and I am sure that Oracle is already working on it, but users be aware.