2 Replies Latest reply on Dec 2, 2013 6:09 PM by AlbertH

    4.0EA3 missing "Oracle" in Connections dialog

    AlbertH

      I use SQL Developer on a Windows 7 machine.  I always install to a folder "C:\Program Files\Oracle\SQL Developer\".  When I update to a new version, I rename the folder for the existing version from "SQL Developer" to something like "SQL Developer 4.0.0.12" and name the folder for the new versin "SQL Developer".  This way, I keep an old version if I want it for anything and my desktop shortcuts are automatically pointing to the new version.

       

      Well, this time, when I installed 4.0EA3 I found I could not connect to any DB.  The "Oracle" tab was missing in the connections dialog.  I only had "Access" and "JBDC".  Well, I finally realized, that this was only an issue when I saved the new version to the folder with the same name that the old version had.  If I run it from a folder called "SQL Developer 4.0.0.13" it works fine.  This hasn't been an issue with any prior version.

       

      I tried not importing the settings from the prior version, but I still have the same issue.  The "Oracle" tab is missing.

       

      So, is there something I need to do to make 4.0EA3 work in a folder with the same name as the prior version had?