1 Reply Latest reply on Dec 11, 2013 3:18 PM by CrazyAnie

    Discoverer 'Value too large' error

    CrazyAnie

      Hi All,

      I have been stuck with a problem with the Oracle Discoverer Plus 10g (10.1.2.55.26) since the last 2 days, tried out all the possible options mentioned on Forums and elsewhere, but somehow nothing seems to help. So I'm turning in to the experts for help. Below is a description:

       

      We have a report on Discoverer which is giving us the 'ORA-12899 value too large for column', whenever we try to schedule it thru the Scheduler. The report runs okay if we run manually. In order to remediate the problem, I did the following:

      1. Identify the Business Areas associated with that report, and map the column in question to its base table.

      2. Could see that the column is a varchar2 column, and so I altered its length from 50 to 200,

      3. Once the column was altered, I deleted it from all the complex folders on its Business Areas, and added it again by copying from the simple folder (which maps directly to the column in the table).

      4. Then I refreshed all the BA's so that the new column length would be picked up everywhere, and the refresh went successfully.

      5. I deleted all the existing scheduled workbooks with errors, and tried to schedule again.

       

      Even then, the workbook still throws the same 'ORA-12899 value too large for column (actual: 57, maximum:50)'. Not sure what step is missing while refreshing the EUL which is causing this error.

      Please advise!

       

      Thanks.

        • 1. Re: Discoverer 'Value too large' error
          CrazyAnie

          Hi,

          Just wanted to mention that we were able to locate and fix the problem yesterday evening. There was another complex folder which also had the same element, and we missed changing that the first time. On doing that change, deleting and rescheduling the report, it started to work perfectly

           

          Thanks.