2 Replies Latest reply: Dec 26, 2013 6:10 AM by legatoo RSS

    Authentication for user weblogic denied

    legatoo

      I am unable to start node managerd server from command prompt.

       

      I installed WebLogic Server Version: 12.1.2.0.0 on Windows 2008 R2 EN Sp1

       

      I started Administration Server succesfully.

      C:\Weblogic\Oracle\config\domains\wl_server\bin\startWebLogic.cmd

       

      I created ihale Managed server but  I couldn't start Managed Server.

      C:\Weblogic\Oracle\config\domains\wl_server\bin

       

      startManagedWebLogic.cmd ihale http://192.168.1.29:7431

       

       

      I'm getting following error.

       

      ####<Dec 25, 2013 12:51:13 AM PST> <Critical> <WebLogicServer> <umman> <ihale> <main> <<WLS Kernel>> <> <> <1387961473813> <BEA-000386> <Server subsystem failed. Reason: weblogic.security.SecurityInitializationException: Authentication for user weblogic denied.

      weblogic.security.SecurityInitializationException: Authentication for user weblogic denied.

      .....

      ....

      Caused By: javax.security.auth.login.FailedLoginException: [Security:090303]Authentication Failed: User weblogic weblogic.security.providers.authentication.LDAPAtnDelegateException: [Security:090295]caught unexpected exception

        at weblogic.security.providers.authentication.LDAPAtnLoginModuleImpl.login(LDAPAtnLoginModuleImpl.java:257)

       

       

      I am able to login administration console same username and password. Username: weblogic Password:xxxxx

       

      I changed the weblogic user password and I tried again. It was unseccesfull.

       

      I created boot.properties file in C:\Weblogic\Oracle\config\domains\wl_server\servers\ihale\security folder.

      I put username and password.

      After I tried to start ihale managed server, boot.properties file didn't encrypted and managed server also didn't started.

       

      I deleted cache, data, tmp folders except logs folder in \\192.168.1.29\c$\Weblogic\Oracle\config\domains\wl_server\servers\ihale and I tried again. It was unseccesfull.

       

      I found something on https://community.oracle.com/message/10653470

       

      Ganesh says:

      Did you restart AdminServer after deleting the LDAP Authentication provider?
      I think your managed server is still trying to authenticate user through ldap authentication provider.

       

      Torrado answers:

      I found that there was a definition in Security Policy of osb_server1 for an user that belonged to deleted LDAP authenticator.
      I deleted it and server started.
      Thanks.

       

      How can I delete definition in Security Policy of ihale for an user that belonged to deleted LDAP authenticator?

       

      Could you please help to solve this problem?

       

      Best Regards.

        • 1. Re: Authentication for user weblogic denied
          Kalyan Pasupuleti-Oracle

          Hi,

           

          You can rename the ldap folder in following directory structure.

           

          %Domain_Name% / servers / <servername> / data/

           

          You will find ldap folder try to rename that folder and then please restart the server again.

           

          If you are try to start through nodemanager then rename the nodemanager under following directory.

           

          %Domain_Name% / servers / <servername> / data/.

           

           

          Try to rename these two folder and restart the nodemanager and start the server again.

           

           

          It will work for you.

           

          Regards,

          Kal

          • 2. Re: Authentication for user weblogic denied
            legatoo

            Hi again;

             

            I found the problem actually it's my mistake.

             

            While I stated the Managed Server, I had written the wrong port number.

            I wrote the managed server port instead of Admin server port.

             

            Thanks Kal.