0 Replies Latest reply: Jan 3, 2014 4:12 PM by user5373812 RSS

    ovm server install failure: UnboundLocalError: local variable 'dev' referenced before assignment


      I'm getting the above error on the server install.

      Here's the first line in the failure:

      File "/usr/lib/anaconda/network.py", line 685, in write

           if dev.get('BOOTPROTO').lower() in ['dhcp', 'ibft']:...


      From my research it appears to be a known bug.  I've tried to install each version of oracle vm server (from 3.03 up) and have found the same error.  Is there any workaround other than installing a new NIC?

      7.2.7. Oracle VM Server Installation Fails
      with Broadcom Gigabit Ethernet Controller

      Installing Oracle VM Server on a system such as the Dell 380, with a Broadcom
      Gigabit Ethernet Controller fails with an error similar to the following
      Traceback (most recent call first): File "/usr/lib/anaconda/network.py", line 685, in write if dev.get('BOOTPROTO').lower() in ['dhcp', 'ibft']: File "/usr/lib/anaconda/yuminstall.py", line 1394, in doPreInstall anaconda.id.network.write(anaconda.rootPath) File "/usr/lib/anaconda/backend.py", line 184, in doPreInstall anaconda.backend.doPreInstall(anaconda) File "/usr/lib/anaconda/dispatch.py", line 207, in moveStep 

      The installer cannot detect the network adapter, so fails to complete the