1 Reply Latest reply on Jan 6, 2014 2:19 PM by thatJeffSmith-Oracle

    oracle.jdbc.driver.T2CConnection.getLibraryVersionNumber()I - another reason

    glauser

      I just hit this error Message in SQL Developer 4.0.0.13. I solved the problem but I googeled a couple of Articles about it, so I found it worth to describe it.

       

      Recently I upgraded to this version of SQLDeveloper and imported all Connections.

       

      Most connections worked well, but with one connection I got this error. It was not depending on the version of the target DB, nor of using thick driver or not: in the properties of this particular connection, "Connect Identifier" was checked instead of "Networt Alias" (using connection Type TNS). Switching back to "Network Alias" solved the problem.

       

      By the way: when configuring Tools - Preferences - Database: Advanced "Use OCI/Thick driver", SQL Developer obviously checks if the specified ORACLE_HOME is on the PATH. It does this case-sensitively even on Windows where directories ar case insensitive, and it adds a hardcoded "bin" to the ORACLE_HOME. In my installation, the directory is named BIN, so if I enter the correctly capitalized Path the test from JDeveloper fails. I have to enter a (errornous) "bin" to save the settings.

      Furthermore, I get a warning that the specified entry be not in the first place for the path specification, even if it is:

      The client home C:\oracle\product\11.2.0\dbhome_1\bin is not the first entry on the PATH. The OCI client may not work correctly.

       

      Pascal