1 Reply Latest reply on Jan 10, 2014 11:25 AM by Nitesh.

    Regarding Apex Listener Configuration using Weblogic Server.

    Nitesh.

      Dear All,

                         

                     Well I have configured my Apex listener in my Web Server and everything worked finely . But my requirement is like i need my URL should like this format http://hostname:port/dev/apex but by default as we know it comes like http://hostname:port/apex/dev (As i given url mapping path /dev) . So i tried by changing name as DEV while deploying APEX.WAR file and i given context root as dev . Now issue is even though i given configuration directory as "dev" but still its showing as " Listener not configured " . Pls someone help me in this . Help is highly appreciated.

       

      My configuration folder is " /home/oracle/apex_listener.2.0.3.221.10.13/dev "

       

      But again apex named sub-directory is created inside this dev automatically .

       

      With Reference to this link i got some idea but its incomplete since its unanswered so i am bit confused too .

       

      https://community.oracle.com/thread/2134379

       

      I thought of changing httpd.conf file and give redirect URL but i am not sure whether can we redirect modulewise since separate "apex" named subdirectory is created inside "dev"  so configuration gets effect as how it will work and mod_rewrite option i seen but can't understand as which one to pick up. Kindly suggest ..

       

      My apex Version is 4.2.3

       

      Apex Listener Version is 2.0.3

       

      If required any other information please ask me .

       

      Regards,

      Nitesh pareek .

        • 1. Re: Regarding Apex Listener Configuration using Weblogic Server.
          Nitesh.

          Dear All,

           

              

           

                    Finally i found the solution for this .  I am giving solution here so that it may be helpful to others who may face difficulties like me,

          Solution:

           

          After changing context root just start your deployed war file and Test it .

           

          While reaching URL,

           

           

          Web page will display showing "apex listener not configured" and it will show you configuration location on webpage itself .

           

          So you just copy all the directories and sub-directories( which got created when you configured your database using war file)  to the location which shown on webpage.

           

          Since we change context root so a context root named directory use to get create inside configured path, so web is unable to find configurations because it gets store inside different directory so just copy all and try . It worked for me very smoothly .

           

          My location was "/home/oracle/apex_listener.2.0.3.221.10.13/apex" (Before changing context root in weblogic server)

           

          Then after changing and starting the deployment again, it became "/home/oracle/apex_listener.2.0.3.221.10.13/dev" , since i given my context root as "dev".

          So here i just copied "apex" directory to dev directory and it worked very finely and i got my desired URL as http://localhost:port/dev/apexhttp://localhostport .

          And all applications working fine too .

           

          Still i felt as its not correct way of doing in security point of view but its the solution i found and i will try apache to redirect my URL .

           

          Thank you,

          Regards,

          Nitesh pareek.