5 Replies Latest reply: Jan 13, 2014 8:13 AM by Michael Peel-Oracle RSS

    auto correction threshold doesn't work

    980863

      After upgrading to the latest MDEX 6.4.1.2, the auto correction seems ignoring my threshold settings.

      In DgraphDefaults.xml I have:

      <arg>--spl_hthresh</arg>

      <arg>1</arg>

       

      if it returns less than 1 results, auto-correct it,  but now, my terms are auto-corrected no matter what, I am using Endeca Assembler 3.1.2, I didn't  enable any auto-phrasing, auto-correction features, I use SearchAdjustment cartridge with all the auto feature set to false.

       

      is it a bug?

       

      Thanks!

        • 1. Re: auto correction threshold doesn't work
          Michael Peel-Oracle

          Hi

           

          So you are searching for a term and Endeca is finding results for this, but the term is still being auto-corrected (note auto-corrected, not just a did-you-mean alternative being returned)?  I've not seen that happen in 3.1.2.  For reference, "1" is the default for the spl_hthresh setting, and as you say means that auto-correction should only occur if the customer's search term(s) return zero results.  Can you give a an example of what is auto-correcting that shouldn't be, i.e. the term you are searching for, the number of results returned for it, and finally the auto-corrected to term and the number of results?

           

          Thanks

           

          Michael

          • 2. Re: auto correction threshold doesn't work
            980863

            Yes, the auto corrections are becoming really weird now,  some the term like "locker" returns 7 results in my indexes, are auto corrected to "like", and "weahter" returns 2 results are auto corrected to "leather".

            Note that, these words "locker", "weather" are in the spell.dat dictionary.

            • 3. Re: auto correction threshold doesn't work
              Greg E.

              I'm curious what use-case you're trying to implement.   Normally, you would leave the Spell flag alone, but tweak the Did You Mean flag depending on the size and type of your data.

               

              Also, can you list the rest of your Dgraph flags?

              • 4. Re: auto correction threshold doesn't work
                980863

                thanks for replying.

                I added the spl flag because I think the default setting doesn't take effect, in PROD, I just turn on spl without any other tweaks.

                 

                <args>

                      <arg>--threads</arg>

                      <arg>2</arg>

                      <arg>--spl</arg>

                      <arg>--dym</arg>

                      <arg>--dym_hthresh</arg>

                      <arg>1</arg>

                      <arg>--stat-abins</arg>

                    </args>

                • 5. Re: auto correction threshold doesn't work
                  Michael Peel-Oracle

                  So your local environment works as expected, but the Production environment has this weird behaviour, is that right?  What is the difference between local and Production - assuming the same data set (as you refer to the same index), but what about versions installed, etc.?  Also, what happens when you access Production via the Endeca reference application (so bypassing Experience Manager)?  Finally, can you check the dgraph request logs to see if there is any additional processing being requested (for example a record filter that would exclude the seven results you see locally, causing it it auto-correct to try and find any results)?