1 2 Previous Next 17 Replies Latest reply: Jan 9, 2014 6:19 PM by petra-K RSS

Install 11gR2 on RedHat 6 or OEL 6

petra-K Expert
Currently Being Moderated

Hi All,

 

I am installing 11gR2 on our Linux RH 6  server.

I got this pre-req setup for the install guide in ORACLE-BASE website (one of my idol site).

 

But when I restarted the server, I got error kernel panic , and can not boot the server

What parameter here caused it to panic? It did not mention specifically. 


Please Helpppp...Thanks.

 

Hosts File

The "/etc/hosts" file must contain a fully qualified name for the server.

<IP-address>  <fully-qualified-machine-name>  <machine-name>

For example.

127.0.0.1       localhost.localdomain  localhost

192.168.0.181   ol6-112.localdomain    ol6-112  

Oracle recommend the following minimum parameter settings.

fs.suid_dumpable = 1

fs.aio-max-nr = 1048576

fs.file-max = 6815744

kernel.shmall = 2097152

kernel.shmmax = 536870912

kernel.shmmni = 4096

kernel.sem = 250 32000 100 128

net.ipv4.ip_local_port_range = 9000 65500

net.core.rmem_default = 262144

net.core.rmem_max = 4194304

net.core.wmem_default = 262144

net.core.wmem_max = 1048586

Add or amend the following lines in the "/etc/sysctl.conf" file.

fs.suid_dumpable = 1

fs.aio-max-nr = 1048576

fs.file-max = 6815744

kernel.shmall = 2097152

kernel.shmmax = 536870912

kernel.shmmni = 4096

#semaphores: semmsl, semmns, semopm, semmni

kernel.sem = 250 32000 100 128

net.ipv4.ip_local_port_range = 9000 65500

net.core.rmem_default=4194304

net.core.rmem_max=4194304

net.core.wmem_default=262144

net.core.wmem_max=1048586  

Add the following lines to the "/etc/security/limits.conf" file.

oracle              soft    nproc   2047

oracle              hard    nproc   16384

oracle              soft    nofile  4096

oracle              hard    nofile  65536

oracle              soft    stack   10240

 

Amend the "/etc/security/limits.d/90-nproc.conf" file as described below. See MOS Note [ID 1487773.1]

# Change this

*          soft    nproc    1024 

# To this

* - nproc 16384

Set secure Linux to permissive by editing the "/etc/selinux/config" file, making sure the SELINUX flag is set as follows.

SELINUX=permissive

Once the change is complete, restart the server.

 

1 2 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points