3 Replies Latest reply: Jan 10, 2014 2:00 AM by Kiran Sundar RSS

Standalone installation of OEM on Oracle Linux having slower response time

Kiran Sundar Newbie
Currently Being Moderated

hi, I have installed OEM on my virtual machine having 70 GB disk space and a swap space of 5GB and 2GB RAM. I have installed Oracle 5.8 Linux and Oracle DB and OEM 11g R2 version. Although the installation went successful, when I try to browse the host console via https://<hostname>:7801/em The login page takes atleast 2 minutes to show up. Its the same with all the pagr browsers. Is that something I am missing wherein the webserver needs to be tuned appropriately. Kindly help.

  • 1. Re: Standalone installation of OEM on Oracle Linux having slower response time
    Rahul-EM Journeyer
    Currently Being Moderated

    Hi ,

     

    Please download the Patch 16743790 and apply it after doing "emctl stop oms -all".

    For instructions on applying the patch, please review the following document:

     

    How to Apply WebLogic Server (WLS) Patches Using Smart Update [Video] Note 876004.1

     

    If your OMS is installed on a NFS file system then we have a known issue addressed in

    12c Cloud Control Performance: Rendering of Cloud Console Pages is Very Slow when OMS is Installed on NFS (Doc ID 1404077.1)

     

    Also you can do the generic UI tuning as per below doc

    12c OEM: How To Set The Large Concurrent UI Load to Improve the Console and OMS Performance (Doc ID 1510981.1)

     

    Regards,

    Rahul

  • 2. Re: Standalone installation of OEM on Oracle Linux having slower response time
    Kiran Sundar Newbie
    Currently Being Moderated

    Thanks Rahul. I figured out an issue with my VM settings. They were not kind of meeting certain pre-requisites mentioned in the Installation guide. I edited the virtual machine settings to contain 2 CPU cores, 8GB RAM post installation of OEM owing to slow response times from the server.  Also, prior to installation of the Oracle DB, I had the user group as dba instead of oinstall. I have now associated the oracle user to the oinstall group instead of dba. Now, I have powered on the virtual machine and started the database and the listener. Now when I try to launch the OMS service, I am not able to get the Management server up and running. The logs show the error on "PolicyStoreContainerNotReadyException" and says 'Failed to search audit definition for component JPS. Reason: oracle.secutiry.jps.service.policystore.PolicyStoreContainerNotReadyException. Kindly let me know what should I do to get the OMS up and running.

  • 3. Re: Standalone installation of OEM on Oracle Linux having slower response time
    Kiran Sundar Newbie
    Currently Being Moderated

    The issue is now resolved. I restarted the database and listener

     

    Restarting the database:

    1. sqlplus "/ as sysdba"

        shutdown immediate

     

    2. sqlplus "/ as sysdba"

        startup

     

    Restarting the listener:

    1. lsnrctl stop

     

    2. lsnrctl start

     

    ReStarting the OMS

     

    1.middleware/oms/bin/emctl stop oms -all

     

    2. middleware/oms/bin/emctl start oms

     

    And this time it worked!!

     

    The response from the webserver was also good.

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points