0 Replies Latest reply: Jan 13, 2014 11:05 AM by todia RSS

    Multiple datasources for Mapviewer WMS

    todia

      Hello,

       

      I have set up a WMS server using mapviewer. I have data sources "prod" and "pub", one is default configured like this in the WMS configuration:

       

      <wms_config host="myhost" port="8080"

                    protocol="http" default_datasource="wms"

                    public_datasources="prod,pub">

       

      The problem I am facing is when I am trying to get layers from the  "pub" datasource. Most of the applications I am using throws me the following errors:


      "The WMS server returned no data from the GetMap request" , "Layer NotDefined" , "Invalid Layer requested" or this other one from QGIS:

       

      "Map request error (Status: 200; Response: <?xml version = '1.0' encoding = 'UTF-8'?>

      <!DOCTYPE ServiceExceptionReport SYSTEM "http://schemas.opengis.net/wms/1.1.1/WMS_exception_1_1_1.dtd">

      <ServiceExceptionReport version="1.1.1">

         <ServiceException code="LayerNotDefined">

            <![CDATA[<oms_error>

      <![CDATA[

      OMS: MAPVIEWER-00003: SQL error occurred while generating map.

      ]]>

      </oms_error>]]>

         </ServiceException>

      </ServiceExceptionReport> "

       

      I tried to add the DATAOURCE Mapviewer parameter but I still get these same errors.

       

      When I switch "pub" from public_datasources to default_datasource everything works fine. It seems that I can get layers only from the default datasource. The problem is that I use several database intances and I relly need to have all datasources working.

       

      Could you help me to know if I'm using it the wrong way or if it is a known bug ?

       

       

      Thank you