5 Replies Latest reply: Jan 15, 2014 6:44 PM by scott.wesley RSS

    iframe not working in HTML region on IE8

    46a643f2-69a8-495f-a146-1062c018ca30

      First post from a new APEX user.  HTML Text Region defined, with source as <iframe src="&P6_GENEOS_URL." style="width:1100px; height:700px;padding:0px;margin:0px" frameborder="0" valign="top"></iframe>

       

      The page referenced by the URL randomly displays and seems to disaply more often when the development environment is open, but even then it does nto always display.  I've tried other sites and same issue - randomly displays.  I've also tried the iframe region plugin but again inconsistently displays the page.

       

      Has anyone seen this or know the cause/fix?  Thanks

        • 1. Re: iframe not working in HTML region on IE8
          scott.wesley

          Sounds like you need to upgrade your decaying browser

          http://caniuse.com/#search=iframe

          • 2. Re: iframe not working in HTML region on IE8
            fac586

            scott.wesley wrote:

             

            Sounds like you need to upgrade your decaying browser

            http://caniuse.com/#search=iframe

            Looks like you need to read the small print on that page more closely:

            The <iframe> element is supported in all browsers tracked here.

            That page documents the lack of support for the sandbox attribute in IE8 & 9, not an inability to render iframe elements. IE8/9 and earlier will simply ignore the sandbox attribute and render the iframe source insecurely. (Which is not to say that upgrading from IE8 isn't necessary, it's just not the solution to this problem.)

             

            From the limited information provided by 46a643f2-69a8-495f-a146-1062c018ca30, the most likely possibilities are problems with the value of the P6_GENEOS_URL item or proxy/firewall issues at their location.

            • 3. Re: iframe not working in HTML region on IE8
              fac586

              46a643f2-69a8-495f-a146-1062c018ca30 wrote:

              Please update your forum profile with a real handle instead of "46a643f2-69a8-495f-a146-1062c018ca30".

              First post from a new APEX user.

              When you post, always include the following information:

               

              • Full APEX version
              • Full database version/edition/host OS
              • Web server architecture (EPG, OHS or APEX listener/host OS)
              • Browser(s) and version(s) used
              • Theme
              • Templates used (include the definitions of any custom or modified templates)

              HTML Text Region defined, with source as <iframe src="&P6_GENEOS_URL." style="width:1100px; height:700px;padding:0px;margin:0px" frameborder="0" valign="top"></iframe>

              valign is not an iframe attribute, and is now obsolete for all elements.

              The page referenced by the URL randomly displays and seems to disaply more often when the development environment is open, but even then it does nto always display.  I've tried other sites and same issue - randomly displays.  I've also tried the iframe region plugin but again inconsistently displays the page.

              How is the value of P6_GENEOS_URL set? Is it set when the iframe content is not rendered? Is it possible for the application to clear the item value? (Use the Session viewer to inspect session state while the application is running.)

               

              Are you located behind a proxy server/firewall? Can you view URLs that are not displayed in a standard browser window?

               

              Is this happening only on IE8? Have you tried other browsers/versions?

              • 4. Re: iframe not working in HTML region on IE8
                scott.wesley

                Interesting - I read the small print, but interpreted the information differently.

                • 5. Re: iframe not working in HTML region on IE8
                  xarg-Xrc

                  This line is not very clear. How can it "Randomly display" something. It will either display the referenced URL or it will not (if there is a problem). 

                  The page referenced by the URL randomly displays and seems to disaply more often when the development environment is open, but even then it does nto always display.