1 Reply Latest reply: Jan 21, 2014 9:52 PM by user7949803 RSS

    Has Oracle changed the security system of the Java applet in previous versions to 1.7_51?

    user851191

      We have one Java Applet application that calls to Javascript and methods javascript calls to java methods, the JRE that we have is JRE 1.7_45 this application worked fine Until January 15 - 2014, when (java Update 1.7_51)  we have the JRE 1.7_45 and now the behavior is different and we have not changed the Java Applet Application, now the javaconsole says "security: LiveConnect (JavaScript) blocked due to security settings.)",I see that the calls of the Java to Javascript goes OK but Javascript to Java doesn't work,  and the file manifest is :

       

      Manifest-Version: 1.0
      Application-Name: Plataforma de Firma
      Application-Library-Allowable-Codebase: *
      Class-Path: Firma.jar
      Permissions: all-permissions
      Caller-Allowable-Codebase: *
      Main-Class: es.uji.security.ui.applet.SignatureApplet
      Codebase: *

       

      We have the clause "Application-Library-Allowable-Codebase" and the applets signed.

       

      - Why Oracle change  the behaviour of security of the other versions of the JRE?
      - We can't  update to other JRE, we have thousands of users, and they don't have administrator permission in their PCs.
      - How could we fix this problem?

       

      Any ideas, thanks a lot.

      Regards

      Jesus