1 Reply Latest reply: Jan 21, 2014 6:29 AM by mseberg RSS

FAILURE_COUNT of V$ARCHIVE_DEST is not incrementing ?

user9085814 Newbie
Currently Being Moderated

Hi All,

 

I have set the second archive destination and protection mode as below

 

SYS@PRD>select protection_mode from v$database;

 

PROTECTION_MODE

MAXIMUM PERFORMANCE

 

 

SYS@PRD>show parameter dest_2

 

NAME                                 TYPE        VALUE

------------------------------------ ----------- ------------------------------

log_archive_dest_2                   string      Service=STAND LGWR SYNC NET_TIMEOUT=30 REOPEN=5 MAX_FAILURE=6 VALID_FOR=(ONLINE_LOGFILE,PRIMARY_ROLE) DB_UNIQUE_NAME=STAND

 

I disconnected the network between the Primary and Standby in order to check the increment of FAILURE_COUNT in the v$archive_dest from Primary.

 

After 10-15 minutes and several 'alter system switch logfile' , i saw that the FAILURE_COUNT is still 2 .

 

SYS@PRD>select NET_TIMEOUT,REOPEN_SECS,MAX_FAILURE,FAILURE_COUNT ,TRANSMIT_MODE ,status from v$archive_dest where dest_id=2

  2  /

 

NET_TIMEOUT REOPEN_SECS MAX_FAILURE FAILURE_COUNT TRANSMIT_MOD STATUS

----------- ----------- ----------- ------------- ------------ ---------

         30           5           6             2 PARALLELSYNC ERROR

 

 

 

As per the above configuration, the network server reopens the connection after 5 seconds and retries up to 6 times. The maximum retry time for 30sec.

 

My question here is , why the FAILURE_COUNT is still 2 and it's not increasing w.r.t time ?

 

Thanks

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points