3 Replies Latest reply: Sep 30, 2004 4:06 PM by 430004 RSS

    Linux Intelligent Agent - OEM cannot discover node

    430004
      Hi,

      I have a Linux AS 2.1 Server with a Oracle 9.2.0.1 Database running. I have 2 Oracle Management Servers ... one is running on this running on the Linux AS 2.1 Server and another on Solaris 9i.
      When start the OEM on the Linux Server and try to discover the Databases on the Linux Server themselves then everything goes fine. When I am trying to discover the databases on the Linux Server from the OEM running in Solaris it does not work.
      The Solaris box has connection to the Linux Server and the repository for the Solaris OEM runs on the Linux Machine.
      When I go back to the OEM on the Linux Machine then I can discover the Solaris box.
      To come to a boddom line here: Whatever I do I am not able to discover the databases on the Linux AS Server besides from the OEM directly running on this box.

      Is that a bug in the Linux Intelligent Agent ? If yes is there a Patch to fix that ? Or is there a work around.

      Please let me know if you have any idea.

      Thanks Marcus
        • 1. Re: Linux Intelligent Agent - OEM cannot discover node
          430004
          I forgot a detail. When I stop the Intelligent agent on the Linux Server then I get the following error message:

          [oracle@dbserver oracle]$ agentctl stop agent

          DBSNMP for Linux: Version 9.2.0.1.0 - Production on 30-SEP-2004 13:10:49

          Copyright (c) 2002 Oracle Corporation. All rights reserved.

          Agent shutdown failed
          [oracle@dbserver oracle]$

          But the agent is shutdown then.
          • 2. Re: Linux Intelligent Agent - OEM cannot discover node
            430004
            Hi again,

            I guess that is part of the issue. This is the output of the nmiconf.log file. Seems to me that the Intelligent Agent is like listening to the wrong port...127.0.0.1 ...that cannot work ... but how to change it ?

            DBSNMP for Linux 2.4.9-e.3: release 9.2.0.0.0 - Production on 30-SEP-04 14:08:58
            Discovering services on dbserver configured on host addresses {dbserver localhost.localdomain localhost 127.0.0.1 {} 10.1.0.10}
            Using oratab file /etc/oratab
            Warning : Error while sourcing third party discovery file emddiscover.tcl : can't read "tabfile": no such variable
            • 3. Re: Linux Intelligent Agent - OEM cannot discover node
              430004
              Ok I figured it out .... the problem is/was the entry of the Loopback Interface entry in the etc hosts:

              127.0.0.1 dbserver localhost.localdomain localhost

              The Intelligent Agent listens to the Loopback Interface now. All incoming requests from and OMS will of course get a timeout because the IP address of the server is 10.1.0.10 .

              You have 2 options now:

              1. Change the entry in the /etc/hosts below to localhost and add an entry to the /etc/hosts file:

              127.0.0.1 localhost localhost.localdomain localhost
              10.10.0.1     dbserver

              Restart the Intelligent Agent and any OMS in your network should be able to discover the note.

              2. In the snmp_rw.ora file you can bind the Intelligent Agent with the following entries to an specific hostname and/or port:

              DBSNMP.HOSTNAME = <hostname or ip address>
              DBSNMP.CS_BASE_PORT = <port number>

              If you start up Agent now you will see in the nmiconf.log file error messages like that:

              Warning: No Listener found for SID db01. db01 will be skipped     
              Warning : No Listener found for SID db02. db02 will be skipped
              Warning : No Listener found for SID db03. db03 will be skipped
              Warning : No Listener found for SID omsrep. omsrep will be skipped

              This is because the Agent looks up in the tnsnames.ora file or whatever you name resolution is and finds the connect descriptors still withe the old name. So all entries in the tnsnames.ora file have to be changed.