6 Replies Latest reply: Apr 24, 2008 10:50 PM by 554596 RSS

    DB Adapter: Message not picked up

    34849
      Hi,

      I have an iConnect 10g working fine with the FTP adapter. Messages come through no problem. But now I'm trying to use the DB adapter to publish a message. I have the adapter running and cannot see anything wrong in the logs, but whenever I create and publish a message (and commit afterwards) I can the message appearing in the MESSAGEOBJECTTABLE and the AOTABLE, but the adapter doesn't pick it up.

      What can cause this?

      Arjan
        • 1. Re: DB Adapter: Message not picked up
          388003
          Hi,

          generally when i have this problem, it's because the field SENDERNAME in the table MESSAGEOBJECTABLE is null.
          Do you fill the sender name into the publish call ?

          rgds,
          Olivier
          • 2. Re: DB Adapter: Message not picked up
            429102
            Hello,

            I have the same problem, I filled the sendername in the messageobjecttable but despite of this the message in the oai schema is not picked up.
            Do you have other idea what can be wrong?
            Thanks,
            Orsi
            • 3. Re: DB Adapter: Message not picked up
              438573
              Anyone a sloution yet??
              We're trying the oposite. FTP adapter sends data to DB Adapter, but nothing happens...
              the messageobjecttable stays empty.
              • 4. Re: DB Adapter: Message not picked up
                416900
                Hi,

                Did you see any errors in the DB adapter log file? Connection errors?

                What is your logging level on the adapters set to? In the adapter.ini file, set the "agent_log_level=2".

                Merlin is correct regarding when your DB Adapter message is not published.

                Some other checks to make are these:-

                Log on via SQL*Plus to your publishing database, connecting to the OAI user (usually OAI/OAI) and do:-

                select count(*) from oai.aotable;

                and

                select count(*) from oai.messageobjecttable;

                If there is the same number of records on there, and your publishing adapter hasn't pick them up, then run this:-

                select APPLICATIONTYPE from oai.messageobjecttable;

                This should be the same as your publishing adapter name.
                Hint: in adapter.ini check the entry for "application= "
                e.g.
                // Application (as created in iStudio) that this Adapter corresponds to.
                application=DB1

                If they are different, or if APPLICATIONTYPE is null, then this is caused because you need to specify the "srcAppName" when you call your publish
                procedure.

                If you send me a mail to ian_scorrer@yahoo.com I'll send you a complete worked, yet simple, DB Adapter to DB Adapter example and code which may help you.

                Rene,

                It is worth noting that ordinarily, the OAI schema has absolutly nothing to do with a subcribing DB adapter. The OAI schema contains the AOTABLE and MESSAGEOBJECTTABLE (MOTABLE), and the AGENT package which creates the message for the publishing event. That is it. The OAI schema does not usually "consume" the subcribed message, and therefore should never end up in the AOTABLE or MOTABLE.

                The target schema to where the subcribed DB message will be posted to is the schema you will define in the DB Adapters "adapter.ini" file.

                Specifically the entries below this line in your adapter.ini
                // Application (spoke) database schema #1 writer information

                Do you have any errors in your log files? The message cannot have just disappeared. Your FTP Adapter must be throwing an error somewhere, or your DB Adapter must be complaining.

                Please can you check you log files for both adapters. If there are any strange errors let us know.

                What type of document are you trying to publish using the FTP Adapter? XML? D3L? If XML, then check out the post "istudio publish event & xml ftp adapter" on this forum.

                Again, if you drop me an email, then I can send you my DB Adapter to DB Adapter example which may help.

                Yan
                • 5. Re: DB Adapter: Message not picked up
                  438573
                  Yan, All

                  I think we've tackled the problem! (at least our problem).
                  We did call our adapter DB_MASTER, but I-Connect seems to have issues with "long" filenames...
                  When we copied it to "DB1" and modified the application name, voila, we had a working adapter....
                  (we found this hidden on metalink: docID 2640747.1).

                  Regards,

                  Rene
                  • 6. Re: DB Adapter: Message not picked up
                    554596
                    HI Yan

                    i found the application type, application name everything mentioned is correct but still if ind the same issue..and when i use the same code in another instance.. this is working.. i am not sure what went wrong.. can u help me on this???

                    please get back to me as soon as possible..

                    thanks in advance
                    Arureddy