This discussion is archived
1 2 Previous Next 25 Replies Latest reply: Mar 6, 2012 10:26 PM by Lacko RSS

ABORTED Apply Process

430777 Newbie
Currently Being Moderated
I've been running into a error message that I can't seem to find much information on. I start my Apply process (that had previously been working), and it aborts a couple minutes later. The alert log shows:

Mon Jan 03 11:54:55 2005
Errors in file e:\oracle\cpd1db_p008_5716.trc:
ORA-07445: exception encountered: core dump [ACCESS_VIOLATION] [0x108522D] [] [] [] []

Streams Apply Reader P006 pid=67 OS id=7324 stopped
Mon Jan 03 11:57:08 2005
Errors in file e:\oracle\cpd1db_p006_7324.trc:
ORA-10388: parallel query server interrupt (failure)

Mon Jan 03 11:57:10 2005
Streams APPLY A004 with pid=50, OS id=7272 stopped
Mon Jan 03 11:57:10 2005
Errors in file e:\oracle\cpd1db_a004_7272.trc:
ORA-12805: parallel query server died unexpectedly

The first trace file listed shows the aforementioned error message:

source segcol number 6 not supported on target MySchema.MyTable.


Does anyone know what this "source segcol number 6..." error refers to?
  • 1. Re: ABORTED Apply Process
    438623 Newbie
    Currently Being Moderated
    hey, 427774
    Did you resolve yours problem?
    I have the same trouble.

    Andrey.
  • 2. Re: ABORTED Apply Process
    439327 Newbie
    Currently Being Moderated
    What version of Oracle are you running and on what OS?
  • 3. Re: ABORTED Apply Process
    438623 Newbie
    Currently Being Moderated
    Oracle Database 10g Enterprise Edition Release 10.1.0.3.0
    on Red Hat Enterprise Linux Advanced Server 3
  • 4. Re: ABORTED Apply Process
    430777 Newbie
    Currently Being Moderated
    Version 10.1.0.3.0
    On Windows 2003
  • 5. Re: ABORTED Apply Process
    412134 Newbie
    Currently Being Moderated
    If you are using the Parallelism parameter of Apply Process, then u'll need to tweak some initialization parameters namely processes and parallel max servers.
    Otherwise, the default setting are not enough if u increasing the parallelism value.

    Regards,
    Raj
  • 6. Re: ABORTED Apply Process
    430777 Newbie
    Currently Being Moderated
    Still no luck. I tried adjusting the Parallelism parameters and other initialization parameters.

    Any other suggestions?
  • 7. Re: ABORTED Apply Process
    412134 Newbie
    Currently Being Moderated
    Hi,
    Have you performed the cleanup properly? Please make sure the cleanup is successful and then try the setup again. Please verify that the following dictionary tables are cleaned up by verifying the following queries:

    SELECT * FROM SYS.DBA_APPLY_ERRORS;
    SELECT * FROM SYS.STREAMS$_PROCESS_PARAMS;
    SELECT * FROM SYS.STREAMS$_RULES;
    SELECT * FROM SYS.STREAMS$_APPLY_PROCESS;
    SELECT * FROM SYS.STREAMS$_APPLY_MILESTONE;
    SELECT * FROM SYS.STREAMS$_APPLY_PROGRESS;
    SELECT * FROM SYS.DBA_APPLY_DML_HANDLERS;

    If there is no other Apply process setup in your db, these queries will return you no rows.

    While I've mentioned cleanup of Apply process only, I'ld always suggest you to do a complete cleanup (includes capture and propagate and bouncing of the src and target dbs) if this is just a test environment that u r working on. I know this is very impractical on a production system.

    I think 10g has a bug free cleanup procedure with it.
    If even that doesn;t work, u may get back to me I could provide u with some cleanup scripts that I used specificaly for 9.2.0.X dbs.

    Regads,
    Raj
  • 8. Re: ABORTED Apply Process
    430777 Newbie
    Currently Being Moderated
    The full cleanup went smoothly. I continued to redo the streams environment on both the source databases and destination database. The apply process ran for a good hour or so, but then aborted with the same problem as stated above. An ORA-07445 (ACCESS_VIOLATION), etc.
  • 9. Re: ABORTED Apply Process
    430777 Newbie
    Currently Being Moderated
    Things are actually looking a bit better. The aborted apply kicked back into gear after I restarted the process. I'll keep you posted.
  • 10. Re: ABORTED Apply Process
    430777 Newbie
    Currently Being Moderated
    Well things had been working well for a couple of days. But today, the apply process aborted with the same error as above.
  • 11. Re: ABORTED Apply Process
    443274 Newbie
    Currently Being Moderated
    I´ve also a problem with an ABORTED Apply Process, but it aborted with another problem: ORA-26714 (User error arisen)
    I have make a cleanup, but this doesn´t work.
    Can you help me?

    Regards,
    Tanja
  • 12. Re: ABORTED Apply Process
    443274 Newbie
    Currently Being Moderated
    What I´ve forgotten. I work with winXP and Oracle Database 10g Enterprise Edition Release 10.1.0.2.0
  • 13. Re: ABORTED Apply Process
    skurup2 Newbie
    Currently Being Moderated
    Peter,
    Check if the apply parameter, ABORT ON ERROR is enabled for your apply. If so disable it.
  • 14. Re: ABORTED Apply Process
    447629 Newbie
    Currently Being Moderated
    Hi,
    I got this error in streams...Pls tell me how to fix it

    *** SESSION ID:(19.172) 2005-07-19 08:48:55.406
    *** 2005-07-19 08:48:55.406
    WARNING: the following transaction makes no progress
    WARNING: in the last 30 seconds for the given message!
    WARNING: xid = 0x000b.026.0000ab2e cscn = 27956820, message# = 3, slavid = 1
    KNACCPD: *******************************************************
    v$lock information for this slave is:
    type:PS, id1:1, id2:1, lmode:4, request:0
    type:SR, id1:1, id2:1, lmode:4, request:0
    type:TM, id1:12702, id2:0, lmode:3, request:0
    type:TX, id1:458788, id2:11336, lmode:6, request:0
    v$session_wait information for this slave is:
    event:STREAMS apply slave waiting for coord message, wait_time:-1, state:WAITED KNOWN TIME,seconds_in_wait:30
    p1:200, p1raw:
    p2:2, p2raw:
    p3:0, p3raw:
    v$session_event information for this slave is:
    event:STREAMS apply slave waiting for coord message, total_waits:2, total_timeouts:0, time_waited:0, average_wait:0, max_wait:0
    Current SQL for this slave is:
    KNACCPD: end ***************************************************
    knacrb: no offending session found (not ITL pressure)
    KNACDMP: *******************************************************
    KNACDMP: Dumping apply coordinator's context at 58fe6b0
    KNACDMP: Apply Engine # 1
    KNACDMP: Apply Engine name STRMADMIN_WALDO_DHFS_STAT
    KNACDMP: Coordinator's Watermarks ------------------------------
    KNACDMP: Apply High Watermark = 0x0000.01aa95cb
    KNACDMP: Apply Low Watermark = 0x0000.01aa95cb
    KNACDMP: Recovery Low Watermark = 0x0000.01aa95c7
    KNACDMP: Fetch Low Watermark = 0x0000.01aaa0d0
    KNACDMP: Oldest SCN = 0x0000.01aa9652
    KNACDMP: Last replicant syncpoint SCN = 0x0000.01aa95a6
    KNACDMP: Last syncpoint at primary SCN = 0x0000.01aa95c7
    KNACDMP: First partition max SCN = 0x0000.01aaa2c0
    KNACDMP: Last partition max SCN = 0xffff.ffffffff
    KNACDMP: Last processed SCN = 0x0000.01aa95cb
    KNACDMP: Conservative SCN = 0x0000.00000000
    KNACDMP: Coordinator's constants -------------------------------
    KNACDMP: number of apply slaves = 1
    KNACDMP: safety level (K) = 1
    KNACDMP: max txns in memory = 80
    KNACDMP: max constraints per table = 119
    KNACDMP: hash table size (in entries) = 8000
    KNACDMP: Coordinator's intervals -------------------------------
    KNACDMP: syncpoint interval (ms) = 0
    KNACDMP: write low watermark interval(ms)= 1
    KNACDMP: Coordinator's timers/counters -------------------------
    KNACDMP: current time = 1121780934
    KNACDMP: low watermark timer = 1121780904
    KNACDMP: shutdown counter = 0
    KNACDMP: syncpoint timer = 1121780904
    KNACDMP: Coordinator's txn counts -------------------------
    KNACDMP: total txns applied = 0
    KNACDMP: total applied at last plwm write= 0
    KNACDMP: apply prog. entries below plwm = 0
    KNACDMP: Coordinator's State/Flags -----------------------------
    KNACDMP: Coordinator's State = KNACST_APPLY_UNTIL_END
    KNACDMP: Coordinator's Flags = 0x104
    KNACDMP: Slave counts ------------------------------------------
    KNACDMP: number of reserved slaves = 0
    KNACDMP: number of admin slaves = 0
    KNACDMP: number of slaves in wait cmt = 0
    KNACDMP: number of safe slaves = 1
    KNACDMP: Slave Lists -------------------------------------------
    KNACDMP: Dumping All Slaves :-
    Slave id = 0, State = 8, Flags = 0, Not Assigned
    Slave id = 1, State = 5, Flags = 1, Assigned Xid = 0x000b.026.0000ab2e
    KNACDMP: End dumping all slaves
    KNACDMP: syncdep slaves = { }
    KNACDMP: cont chunk slaves = { }
    KNACDMP: cont slaves = { }
    KNACDMP: exec txn slaves = { }
    No idle slave
    *** 2005-07-19 08:49:08.750
    error 12805 in STREAMS process
    ORA-12805: parallel query server died unexpectedly
    OPIRIP: Uncaught error 447. Error stack:
    ORA-00447: fatal error in background process
    ORA-12805: parallel query server died unexpectedly

1 2 Previous Next