3 Replies Latest reply on Jan 25, 2005 5:38 AM by 94256

    Error connecting to OAI Repository

    94256
      We are unable to process an inbound file.
      The DBadapter throws up the following mesage.

      Fri Jan 21 07:56:04 SGT 2005: Error connecting to the OAI Repository. Please make sure that the hub database and the OAI Repository are started properly. On
      ce everything is started properly, the connection will be automatically re-established. However, if you have provided incorrect parameters concerning your hub
      database or the OAI Repository during installation of this Adapter, please stop the Adapter, fix the information and restart.
      com.sun.corba.se.internal.corba.AnyImpl@7447c5
      at oracle.aob.repository.aobRepositoryCartridge.RepositoryExceptionHelper.read(RepositoryExceptionHelper.java:10)
      at oracle.aob.repository.aobRepositoryCartridge._st_AgentATMgr.getDVMapForAT(_st_AgentATMgr.java:1372)
      at oracle.oai.agent.server.OAIRepositoryImpl.readDVMTable(OAIRepositoryImpl.java:991)
      at oracle.oai.agent.server.MetadataManager.readDVMTableFromRepo(MetadataManager.java:1289)
      at oracle.oai.agent.server.MetadataManager.getDVMTable(MetadataManager.java:868)
      at oracle.oai.agent.server.MetadataManager.getXref(MetadataManager.java:684)
      at oracle.oai.agent.client.XrefHelper.getXref(XrefHelper.java:113)
      at oracle.oai.agent.server.transform.BuiltInTransformation.lookupXref(BuiltInTransformation.java:2129)
      at oracle.oai.agent.server.transform.BuiltInTransformation.transform(BuiltInTransformation.java:273)
      at oracle.oai.agent.server.transform.MessageTransformer.processStackFrame(MessageTransformer.java:833)
      at oracle.oai.agent.server.transform.MessageTransformer.processTransformMetadatalet(MessageTransformer.java:474)
      at oracle.oai.agent.server.transform.MessageTransformer.transformMessage(MessageTransformer.java:268)

      *********************************************
      The only change we tried was to change the passwords of oaihub902.When we got the above error we reverted back to the old password and we still get this error.

      Any help is appreciated.Thanks, Kiran
        • 1. Re: Error connecting to OAI Repository
          434422
          Hi Kiran,

          We experienced the same problem with a standard ftp adapter. The hub database was running, the repository was running and the other adapters were doing fine.

          We solved the problem by restarting the repository.

          We did not find out what the problem was, but it was probably the repository.....

          /Peter
          • 2. Re: Error connecting to OAI Repository
            94256
            Thanks Peter.
            I am glad you were able to resolve by restarting the adapter.
            We tried that too ,unfortunately it did not help us.
            We also removed the persistence,even whatever was in the oai_hub_queue,ip_qtab before restarting but it didn't help.
            Regards,
            Kiran
            • 3. Re: Error connecting to OAI Repository
              94256
              Hi,
              Ultimately found out what the issue was.
              The reason it was complaining of not being able to connect to the repository was because of an missing table in the hub schema.This table was being used for domain value maps.Still do not know why and how this table went awol.

              The error message in the dbadapter log(shown above)was not much help,but the better or more meaningful message was in the reposlog.txt ,generated when the repository is started.
              It complained of "ORA_942 Table or view not found".
              We ran a trace on this and then found out which table it was.Recreated the table and things are back to normal now.Thanks to Marty at Oracle support for helping us figure it out.