3 Replies Latest reply on Sep 27, 2005 8:52 AM by 456619

    Samsys RFID Driver

      I use the Samsys Driver provided on the Oracle Edge Extensions site. I use the SAMSys MP9320 2.7 EPC Reader. This Reader is connected via Serial Port to my Computer. In the Configuration I set the the uri - String to: esc://com?port=COM1&baud=9600

      If I start the edge-Server I get the following error message:
      com.thoughtworks.xstream.io.StreamException: Expected ';'.
      at com.thoughtworks.xstream.io.xml.DomDriver.createReade
      r(Unknown Source)

      Could anyone help me?
        • 1. Re: Samsys RFID Driver
          There are two problems:

          The first problem is with the extension parameter default values I think. It's a bug in the unmarshalling code (which is fixed in code) that forgets to convert the special characters.

          Basically, go to the tag //EdgeServer/DriverList/Driver/[Name=SamsysDriver]/Parameters/Parameter[@name=uri] and empty out the string.

          Secondly, since it is an xml file, it must be well-formed, meaning you have to make sure you don't have special characters in your parameter values.

          Whenever you have an ampersand in a literal string in XML, you must convert them to entitities. Therefore, you have to convert all your & to &

          For example, instead of the string you provide:

          You should use:

          Please use a XML checker, or even just a web browser to make sure the XML is good before loading it.

          Hope this helps.
          • 2. Re: Samsys RFID Driver
            as Sam said this error is because of bad-formed xml

            in his explain, & appeared as & because the html here in the forum

            the code (remove the blank spaces) would be "& a m p ;" that would represent & in the XML file.
            • 3. Re: Samsys RFID Driver
              Thanks a lot to both of mk and sam......
              it was the problem with the bad formed xml only......
              i tried "esc://tcp?ip=" istead of "esc://tcp?ip="
              and it worked.....