0 Replies Latest reply on Oct 3, 2005 9:54 AM by 456893

    FTP adapter failing sometimes, msg:Error connecting to the OAI Repository

    456893
      Hi,

      I have imported a dump due to curropt metadata definition. The import was successful without any warning/error.

      I have recreated the event , but when I am testing the same, getting following error in the FTP adapter, though the adadpter is started successfully, connecting to hub /repository, still trowing below errror when it translates a file:
      Sometimes it works when the adadpter is killed & restarted.
      Ususally happening when a new event is created & run for the first time...

      <A N = "do_no">428997</A>
      <A N = "mdo_no">
      </A>
      </AO>
      </AO>
      </AO>
      </B>
      </MSG>.
      Mon Oct 03 17:18:45 SGT 2005: Transport logs:
      Message linked list has 0 elements.
      Mon Oct 03 17:18:45 SGT 2005: Transport logs:
      FileReceiver.sendResponse() completed.
      Mon Oct 03 17:18:45 SGT 2005: Transport logs:
      FileReceiver.receive() is invoked.
      Mon Oct 03 17:18:45 SGT 2005: Transport logs:
      The message queue is empty.
      Mon Oct 03 17:18:45 SGT 2005: Initializing connection to the Repository...
      Mon Oct 03 17:18:46 SGT 2005: Connected to the Repository.
      Mon Oct 03 17:18:46 SGT 2005: Error connecting to the OAI Repository. Please make sure that the hub database and the OAI Repository are started properly. Once everything is started properly, the connection will be automatically re-established. However, if you have provided incorrect parameters concerning your hub database or the OAI Repository during installation of this Adapter, please stop the Adapter, fix the information and restart.
      oracle.aob.repository.aobRepositoryCartridge.RepositoryException

      Any pointers on this will be a great help for me.

      Regards,

      MOhit