1 Reply Latest reply: Jan 4, 2006 3:27 PM by 207512 RSS

    Tag Encoding doesnot occur

    452426
      Hi All,

      I wanted to know if anyone was able to accomplish the tag write to Alien RFID reader. I am also attempting similarly,

      Edg_utl.sendtoedge (101, 0, ,’MySite', ‘Alien RFID Reader’, ‘<methods> <method> <params> <param name ="tagid"> 307401D4C00159000000AECA </param> </params> </method> </methods>’, sysdate,’src’,’cor’);

      The event is succssfully executed but tag doesnot get encoded. Below is a clip from the log fileon the same,

      Fri Sep 30 16:59:53 CDT 2005: The device with name: Alien RFID Reader does exist on this machine, attempting to process instruction. Type = 101, Subtype = 0
      Fri Sep 30 16:59:53 CDT 2005: Device with name: Alien RFID Readersuccessfully processed msg
      Fri Sep 30 16:59:54 CDT 2005: Dispatching event with id: 0000 0000 0000 6102 9202 5461
      Fri Sep 30 16:59:54 CDT 2005: Dispatching event with id: 1
      Fri Sep 30 16:59:54 CDT 2005: StreamsDispatcher: Sending msg:Type = 200, Subtype = 0Devicename = Alien RFID Reader
      Fri Sep 30 16:59:54 CDT 2005: StreamsDispatcher: Msg sent:Type = 200, Subtype = 0Devicename = Alien RFID Reader
      Fri Sep 30 16:59:54 CDT 2005: StreamsDispatcher: Sending msg:Type = 1, Subtype = 0Devicename = null
      Fri Sep 30 16:59:54 CDT 2005: StreamsDispatcher: Msg sent:Type = 1, Subtype = 0Devicename = null
      Fri Sep 30 16:59:55 CDT 2005: Dispatching event with id: 0000 0000 0000 6102 9202 5461
      Fri Sep 30 16:59:55 CDT 2005: StreamsDispatcher: Sending msg:Type = 200, Subtype = 0Devicename = Alien RFID Reader
      Fri Sep 30 16:59:55 CDT 2005: StreamsDispatcher: Msg sent:Type = 200, Subtype = 0Devicename = Alien RFID Reader
      Fri Sep 30 16:59:56 CDT 2005: Dispatching event with id: 0000 0000 0000 6102 9202 5461

      Please also note the 'DeviceName = null' , that occurs after the execution of the instruction.

      Would appreciate if anyone in the group could help me resolve this.

      Thanks,
      Vijay
        • 1. Re: Tag Encoding doesnot occur
          207512
          I assume this is for 10.1.3.0 (since you're writing to Alien)

          Please first try it with the JSP test page:
          /edge/tools/writeTag.jsp.

          It shows a form and will do the event formating for you.

          If that doesn't work, then we might have a setup problem.

          Thanks -- Sam