11 Replies Latest reply: Feb 25, 2006 4:00 PM by 493664 RSS

    ORACLE not available problem 10g release 2

    458907
      hi all,
      I encounter a problem for everytime a restart the server and login to the server using sqlplus, the err as follow...


      ERROR:
      ORA-01034: ORACLE not available
      ORA-27101: shared memory realm does not exist


      when i check the oracle services, all are started. but in the oradim.log, some err found as below...


      Mon Oct 10 10:47:48 2005
      c:\oracle\product\10.2.0\db_1\bin\oradim.exe -startup -sid db01 -usrpwd * -log oradim.log -nocheck 0
      Mon Oct 10 10:47:50 2005
      ORA-12560: TNS:protocol adapter error


      and also a sqlnet.log generated as below...


      Fatal NI connect error 12560, connecting to:
      (DESCRIPTION=(ADDRESS=(PROTOCOL=BEQ)(PROGRAM=oracle)(ARGV0=oracledb01)(ARGS='(DESCRIPTION=(LOCAL=YES)(ADDRESS=(PROTOCOL=beq)))'))(CONNECT_DATA=(SID=db01)(CID=(PROGRAM=c:\oracle\product\10.2.0\db_1\bin\oradim.exe)(HOST=TEST134)(USER=SYSTEM))))

      VERSION INFORMATION:
           TNS for 32-bit Windows: Version 10.2.0.1.0 - Production
           Oracle Bequeath NT Protocol Adapter for 32-bit Windows: Version 10.2.0.1.0 - Production
      Time: 10-OCT-2005 10:47:50
      Tracing not turned on.
      Tns error struct:
      ns main err code: 12560
      TNS-12560: TNS:protocol adapter error
      ns secondary err code: 0
      nt main err code: 530
      TNS-00530: Protocol adapter error
      nt secondary err code: 2
      nt OS err code: 0


      the most funny thing is that when i copy the command on the oradim.log file
      ----------------
      c:\oracle\product\10.2.0\db_1\bin\oradim.exe -startup -sid db01 -usrpwd * -log oradim.log -nocheck 0
      ---------------
      and execute it, I can login successfully in the sqlplus... so what is the possible cause of this ?? One point to add is that I am using 2003 with 10g release 1 installed originally and worked fine, after I have unstalled the release 1 and installed release 2, the problem occur......would anyone help ?? thx so much for that...